tried everything (Swap Caps_Lock and Control_L) nothing works!

Marko Turk marko at markoturk.info
Wed Mar 25 13:32:10 UTC 2015


On Wed, Mar 25, 2015 at 08:57:08AM -0400, William Bulley wrote:
> This is really annoying.  I know I have used xmodmap(1) in the past
> and it served me well.  I now have a Dell keyboard on a Dell system
> and I can't get the caps lock key swapped with the left control key.
> 
> Here is what I have now (yes, both -- belt and suspenders...):
> 
> unix% head -6 $HOME/.xmodmaprc
> remove Lock = Caps_Lock
> remove Control = Control_L
> keysym Control_L = Caps_Lock
> keysym Caps_Lock = Control_L
> add Lock = Caps_Lock
> add Control = Control_L
> unix% grep modmap .xinitrc
> /usr/local/bin/xmodmap $HOME/.xmodmaprc
> unix% grep swap /etc/X11/xorg.conf
>         Option      "XkbOptions" "ctrl:swapcaps"
> unix% pkg info | grep xorg-server
> xorg-server-1.14.7_2,1         X.Org X server and related programs
> 
> I have rebooted the system as well as restarting Xorg to make sure
> everything was running from a fresh beginning.
> 
> One of the above should have worked, but in my xterm window(s) the
> caps lock is still CAPS LOCK, sigh...  Can anyone provide a clue?
> 

Hi,

this works for me (I put it in .xinitrc):
setxkbmap -option ctrl:nocaps

BR,
Marko
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20150325/71a9adfc/attachment.sig>


More information about the freebsd-questions mailing list