tried everything (Swap Caps_Lock and Control_L) nothing works!

William Bulley web at
Wed Mar 25 13:03:16 UTC 2015

This is really annoying.  I know I have used xmodmap(1) in the past
and it served me well.  I now have a Dell keyboard on a Dell system
and I can't get the caps lock key swapped with the left control key.

Here is what I have now (yes, both -- belt and suspenders...):

unix% head -6 $HOME/.xmodmaprc
remove Lock = Caps_Lock
remove Control = Control_L
keysym Control_L = Caps_Lock
keysym Caps_Lock = Control_L
add Lock = Caps_Lock
add Control = Control_L
unix% grep modmap .xinitrc
/usr/local/bin/xmodmap $HOME/.xmodmaprc
unix% grep swap /etc/X11/xorg.conf
        Option      "XkbOptions" "ctrl:swapcaps"
unix% pkg info | grep xorg-server
xorg-server-1.14.7_2,1         X.Org X server and related programs

I have rebooted the system as well as restarting Xorg to make sure
everything was running from a fresh beginning.

One of the above should have worked, but in my xterm window(s) the
caps lock is still CAPS LOCK, sigh...  Can anyone provide a clue?




 /"\   ASCII RIBBON          / William Bulley
 \ /   CAMPAIGN AGAINST     / 
  X    HTML E-MAIL AND     / E-MAIL: web at

72 characters width template ----------------------------------------->|

More information about the freebsd-questions mailing list