Configure error for cyrus-sasl2-saslauthd after upgrade

Robert Fitzpatrick robert at
Wed Mar 25 12:37:42 UTC 2015

I upgraded a FreeBSD 8.4 server to 10.1 and all went well for the most 
part except I can't get saslauthd to build now. I run saslauthd with the 
ldap flag and if I use the binary package install, it complains the ldap 
is an unknown mechanism. So, I remove the binary package and when I try 
to build from ports....

configure: error: in 
configure: error: C compiler cannot create executables
See `config.log' for more details.
===>  Script "configure" failed unexpectedly.
Please report the problem to ume at [maintainer] and attach the
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

In the config.log, this is the error section.....

Selected GCC installation:
configure:3064: $? = 0
configure:3071: cc -V >&5
cc: error: argument to '-V' is missing (expected 1 value)
cc: error: no input files
configure:3075: $? = 1
configure:3098: checking for C compiler default output file name
configure:3120: cc -O2 -pipe  -fstack-protector -DLDAP_DEPRECATED 
cc: error: unknown argument: '-R/usr/local/lib'
configure:3124: $? = 1
configure:3162: result:
configure: failed program was:
| /* confdefs.h.  */
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE "cyrus-sasl"
| #define VERSION "2.1.26"
| /* end confdefs.h.  */
| int
| main ()
| {
|   ;
|   return 0;
| }
configure:3168: error: in 
configure:3170: error: C compiler cannot create executables
See `config.log' for more details.

I have tried to force rebuild of all ports using portupgrade and applied 
all Freebsd updates, rebooted, still get the same error. I've searched 
for a solution on the web, but can't find anything specific to my error. 
Can someone please tell me what I might be able to do to solve this 
issue? Other packages build fine, I've removed cyrus-sasl and rebuilt to 
no avail and many other packages.

Thanks, Robert

More information about the freebsd-questions mailing list