Jail with bitblee running, connection timed out

Matthew Seaman matthew at FreeBSD.org
Wed Mar 11 14:09:33 UTC 2015

On 2015/03/11 13:59, 1126 (Christian Lask) wrote:
> `stockstat -l4p 6667` reveals that it is indeed listening on the jails
> IP on port 6667. In Weechat then I added a new server (localhost/6667)
> and tried to connect to it. This connection however is never established
> and times out. I do not know how to debug this properly and have no idea
> what is wrong here. Configuration of both seems pretty straightforward,
> so I don't know what I am doing wrong here.

Jails tend not to have localhost (ie. or ::1) addresses
accessible to them[*].  Try logging into the jail and examine the output
of 'ifconfig -a' -- compare it with what you get on the host system.

If you want some processes within the same jail to be able to
communicate through a network-like protocol, then unix domain sockets
are the way to go, assuming that the software you want to run supports
them.  Failing that, you'll have to use the jail's allocated IP number(s).



[*] There is a new alternative style of jail, called a VNET jail, which
you could use and that do have their own loopback interfaces and
localhost addresses, but these are still fairly new, somewhat more
complicated to setup and still not thoroughly debugged.  Last I checked,
they also required you to run a custom kernel.

More information about the freebsd-questions mailing list