Jail with bitblee running, connection timed out

1126 (Christian Lask) mail at elfsechsundzwanzig.de
Wed Mar 11 13:59:56 UTC 2015

Hello there!

This might just be my first posting ever to this very mailinglist. :)

I am currently deploying FreeBSD 10.1 on a spare server to learn how
that works and - if everything works out - use this server for a
manifold of tasks. One of them would be and currently is to run a
Weechat instance in a jail to which I then connect via SSH. This is working just
fine including NAT via PF and everything.

Yesterday I tried to add bitlbee to the mix to connect to Twitter and
Jabber via this Weechat instance. This however did not work. I
configured bitlbee to run as ForkDeamon and by the user bitlbee and
started it via `service bitlbee start`.

`stockstat -l4p 6667` reveals that it is indeed listening on the jails
IP on port 6667. In Weechat then I added a new server (localhost/6667)
and tried to connect to it. This connection however is never established
and times out. I do not know how to debug this properly and have no idea
what is wrong here. Configuration of both seems pretty straightforward,
so I don't know what I am doing wrong here.

Maybe one of you could point me in the right direction?

Thanks in advance!

More information about the freebsd-questions mailing list