All of a sudden, problems with X

Polytropon freebsd at
Tue Jul 22 04:19:05 UTC 2014

On Mon, 21 Jul 2014 21:04:40 -0700, David Benfell wrote:
> On Tue, Jul 22, 2014 at 05:14:23AM +0200, Polytropon wrote:
> > On Mon, 21 Jul 2014 19:46:43 -0700, David Benfell wrote:
> > > Now I've rebooted and I can't get Xorg working properly at all.
> > 
> > Did you perform any updates?
> > 
> Yes, having pondered the situation since my original message, it
> occurs to me there may be a mismatch between Xorg compiled from a port
> (I think it may have been rebuilt) and a driver installed via pkg. How
> would I check?

The easiest thing now would be to remove X and

	a) install it _and_ its dependencies from ports,
	   ports tree updated of course

	b) install it via pkg.

I've been installing a FreeBSD 10 system with X (defaulting to HAL)
via pkg, and this worked after following the required steps as per
the handbook.

> > > Xorg -configure yields only a black (apparently not blank) screen. I
> > > tried adding the magic to allow CTRL/ALT/BACKSPACE but it doesn't
> > > work (yes, I rebooted after adding the magic).
> > 
> > There currently are two magics for that: The "magic in xorg.conf"
> > when using X without HAL, and the "magic with XML" involving the
> > configuration files scattered across /usr/local/ when using HAL.
> > Do you use X with or without HAL? If with, is everything running?
> > 
> Yes, I'm running HAL. I understand this is what makes detecting a USB
> keyboard (I have a *full size* keyboard this way) and a USB mouse (my
> precious trackball) possible.
> service reports that hal is running. ps doesn't indicate anything
> amiss (at least as far as I know):
> hald is running as pid 1331.

Good, as this is a requirement, it has been verified. You can't
be cautious enough. :-)

> > > The only way out of the
> > > black screen is CTRL/ALT/DEL, which reboots the system.
> > 
> > This key combination usually does _nothing_ when within X, so if
> > it works, it seems to suggest that you have exited X, you're back
> > at the text mode console, but you can't see it (blank screen).
> > 
> So how would I get a prompt back in this situation?

That's a really hard question. :-)

In situatins where X is exiting, but failing to restore the
text mode console, there usually is no real way to cure this
problem. I had a comparable problem with my nVidia graphics
card when switching to text mode from a running X with the
Ctrl+Alt+PF1 key combination - black screen, "no signal",
switched back Ctrl+Alt+PF9 - X as expected, and back Ctrl+Alt+PF1 -
and the text mode was there. However, when X is _not_ running,
switching "back and forth" is impossible. You could try to
blindly enter "startx" and hope it helps. It probably won't

> > > If I use startx, I get a correct display, but the mouse doesn't work.
> > 
> > Often a problem related to HAL. Make sure you exactly follow the
> > handbook in getting the input working. In case you have updated X,
> > also update its "input" components.
> > 
> Okay, so see above. When installing the system (it's a fairly fresh
> installation), I really didn't have to do anything to make all this
> work. One of the very first things I installed was gnome2 and I set
> the relevant variables for HAL, dbus, and gnome.

Me too - I installed a FreeBSD 10 system using pkg and with
Gnome (and gdm). Not everything worked as expected from the
past, especially keyboard language settings had to be done
differently (see "HAL XML magic"), and automount was a total
desaster. Somehow, I still got it working... can't even
remember how... :-)

> But I wouldn't be the least bit surprised if an input component hasn't
> been updated properly. Is there a sane way of making sure all this is
> done right?

Remove X and dependencies, install them again in a "contiguous"
manner as mentioned. This will probably be faster and easier than
trying to "repair" the current situation. However, a "pkg update"
would at least be worth a try.

> > From the X log, those are disappointing:
> > 
> > > [   544.688] (**) ModulePath set to "/usr/local/lib/xorg/modules"
> > > [   544.688] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
> > > [   544.688] (WW) Disabling Mouse0
> > > [   544.688] (WW) Disabling Keyboard0
> > > [   546.330] 
> > > [   546.330] 
> > > Xorg detected your mouse at device /dev/sysmouse.
> > > Please check your config if the mouse is still not
> > > operational, as by default Xorg tries to autodetect
> > > the protocol.
> > > [   546.330] 
> > 
> > Again, check with the handbook's section about X configuration.
> > You probably have a problem with HAL. Many people seem to have. :-)
> > 
> >
> > 
> >
> These seem to assume I have an xorg.conf. I was getting by without.
> And Xorg -configure doesn't work. So now what?

If you don't have (and don't need) a xorg.conf, you also don't
need to run "Xorg -configure" (because this only generates that
file). Running X without xorg.conf works fine these days, and
if you're running HAL anyway, it should be fine not to bother.
As I said, I did everything as listed in the handbook to get
things working. Having an "as clean as possible" starting situation

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list