SOLVED: Re: All of a sudden, problems with X

David Benfell benfell at
Tue Jul 22 05:21:41 UTC 2014

Polytropon writes:
> The easiest thing now would be to remove X and
> 	a) install it _and_ its dependencies from ports,
> 	   ports tree updated of course

I think this is what I did. The command I used was:

portmaster -w -r xorg-server

The problem reported here now seems to be solved. I have a mouse again. I  
haven't tried Xorg -configure, but I've got fluxbox working from startx  
again. And I haven't tried gdm to see if all this latest has fixed whatever  
was wrong there.

It does seem there are some gotchas with this latest version of Xorg. One  
is that it attempts to respond to my mismatched dual-head setup. It didn't  
get screen dimensions right at all and fell back to an ugly common  
denominator. It happens the big beautiful screen is destined for a server  
that should be arriving in a couple days anyway, so I'm just disconnecting  
it a bit early. The small notebook screen will suffice until then.


David Benfell
See if you do not understand the  
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 811 bytes
Desc: not available
URL: <>

More information about the freebsd-questions mailing list