mutt and http//url???

Gary Kline kline at
Sat Mar 23 01:20:34 UTC 2013

On Sat, Mar 23, 2013 at 01:20:18AM +0100, Polytropon wrote:
> On Fri, 22 Mar 2013 14:36:15 -0700, Gary Kline wrote:
> > 	in the past couple years i've sub'd to the nytimes and other places
> > 	where the http string is several dozens of bytes.  in my mutt 
> > 	at least, there are "+" marks embedded at the beginning of each
> > 	new lines.  so that when i mouse lick on the url, i almost 
> > 	invariably get  either Nothing from my browswer, or the wrong 
> > 	page.
> That's to be expected. A URL covering several lines _can_ be
> copied (selected) when the line wrap is "uninterrupted". It
> will even work for double- or triple-click (select word, select
> line) with the normal edit buffer (left swipe to select, in
> Firefox middle click or mousewheel press to go to URL). As the
> '+' character will be part of the wrapped URL (which can span
> several lines), the URL will be wrong, as you've seen.
> > 	i've googled for days.  zero.  im finally asking the top list
> > 	on the web.   can anybody clue me in?  i'm  using linux/gnome/mutt.
> > 	but it shouldnt make any difference. [?!]
> If I remember correctly, there's a way to disable the line break
> emphasizer ('+' character) in the display. Have you tried
> 	set markers=no
> in your ~/.muttrc? Or was it
> 	unset markers
> Something with "markers"... I'm not fully sure if this is the
> setting you're searching for, but go ahead and try it.

	theres a 'set markers' that defaults to yes. I edited it to no
	and, presto, no mo' '+' in the url strings.  ---how you ever 
	remembered  the variable 'markers' is beyound me, but yup.

	anyway, with my konsole at std size, ~37x80, I moused dead-on 
	the http string.  same as before: the string showed up from the
	'http://.....' to the eol.  and when I clicked, I got garbage.  

	wait, there's more.  I blew up the konsole  until it filled the
	entire  screen.  [i did this once before and got the right page.]
	it still worked.  no '+' line break, but still.

	it's a bear to have to enlage the xterm/konsole just to read
	some mail, but it works with the two embedded urls that I've tried
	so far.  why?  dunno.
> -- 
> Polytropon
> Magdeburg, Germany
> Happy FreeBSD user since 4.0
> Andra moi ennepe, Mousa, ...
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

 Gary Kline  kline at  Public Service Unix
              Twenty-six years of service to the Unix community.

More information about the freebsd-questions mailing list