SPAM: Re: ZFS root, error 2 when mounting root

bw.mail.lists bw.mail.lists at
Tue Feb 26 22:59:32 UTC 2013

On 02/26/2013 04:31 PM, Chad M Stewart wrote:
> I've been down this road recently with 9.1-release.  I ended up adding these lines to end of my script
> ## The next two are "hacks" in my book, without the last line, on reboot
> ## it gets stuck trying to find zfs:zroot/ROOT, but somehow the -f or reboot "fixes"
> # this quirk
> zpool export zroot
> zpool import -f zroot
> reboot
> Without the altroot it replaces the live CD mounts, and basically renders the system pointless, except that it works on reboot.  :)   I tried all sorts of other ways to make it work, mounting zroot and specifying a cache file, then cp the file over, etc., nothing I did worked except the above.  There is probably a cleaner/better way but I was not able to find it.

I seem to remember trying that too, forced import, but after an 
unsuccessful reboot, not at the end of the script. It didn't work for 
me. Anyway, thanks for the answers, it's a bit more clear now.

More information about the freebsd-questions mailing list