No sound from speaker, using Realtek ALC269 and snd_hda

Big Yuuta at
Sun Oct 28 21:20:34 UTC 2012

Unfortunately, trying with the different combinations didn't work.

I wrote this tiny script just to make sure I'm not forgetting a case:

echo "testing with: $1 - $2";
kenv hint.hdaa.0.gpio_config="0=$1 1=$2";
kldunload snd_hda.ko;
kldload snd_hda.ko;
mplayer song.mp3;

and I run it like this:

./ set set
./ set clear
./ clear set
./ clear clear

And nothing came out of the speaker, alas :(

What's strange is that the speaker actually works with OSS from ports,
but when I use it (OSS) with mplayer it crashes the whole system
whenever I try to skip in a video/audio file

On Sun, Oct 28, 2012 at 9:58 PM, Big Yuuta < at> wrote:
> On Sun, Oct 28, 2012 at 9:42 PM, Alexander Motin <mav at> wrote:
>> On 28.10.2012 22:09, Big Yuuta wrote:
>>>> CODEC configuration looks good and I see no problems in driver output. I
>>>> think most likely problem is in CODEC wiring and power amplifier. Your
>>>> CODEC
>>>> has two GPIO lines and EAPD line. That gives 8 possible combinations. I
>>>> would recommend you to try them all. GPIOs, as you tried could be set
>>>> with
>>>> hint.hdaa.0.gpio_config tunable. EAPD line can be controlled (0 or 100)
>>>> by
>>>> the ogain mixer control.
>>> You mean combinations like:
>>> hint.hdaa.0.gpio_config="0=set 1=set 2=set"
>> As I've told, there are only two GPIO pins, so only "0=X 1=Y", plus ogain
>> mixer control.
> So that would be:
> hint.hdaa.0.gpio_config="0=set 1=set"
> hint.hdaa.0.gpio_config="0=set 1=clear"
> hint.hdaa.0.gpio_config="0=clear 1=set"
> hint.hdaa.0.gpio_config="0=clear 1=clear"
> which I try with:
> mixer ogain 0:0
> mixer ogain 100:100
> I'm going to check once again, but I think that unfortunately that didn't work.
> I hope that I forgot a combination!
> Thanks again, Alexander

More information about the freebsd-questions mailing list