Problem with pkgconf and glib.

Bas Smeelen b.smeelen at
Mon Jul 30 16:57:05 UTC 2012

On 07/30/12 18:21, Michael Powell wrote:
> Jeff Tipton wrote:
>> On 07/30/2012 17:19, Christopher Hilton wrote:
>>> I'm trying to build emacs with gtk2 on my build box and I'm running into
>>> trouble with pkgconf from /usr/ports/devel/pkgconf. The build process
>>> dies in devel/gobject-introspection and complains that it cannot find
>>> header files for gio-unix-2.0. From what I can see the problem looks like
>>> the fact that pkgconf is returning the wrong include path for these
>>> header files, running:
> [snip]
>> I have the same problem with devel/gobject-introspection. It's also a
>> dependecy for Xorg.
>> A couple of days ago devel/pkg-config was removed from ports as
>> deprecated, and replaced with devel/pkgconf, and consequently the build
>> dependencies of many ports were changed. Maybe this recent change is not
>> thoroughly worked out?
> When I first saw it in UPDATING and did the command I believe it was not
> completely correct, as it did nothing. That was something on the order of 3
> or 4 days ago. Just csup'd today and the command in UPDATING I think
> contained something slightly different, and is now correct.
> Before, it did not remove/replace pkg-config. Today it did. Perhaps a ports
> tree refresh and if using portupgrade do this:
> portupgrade -fo devel/pkgconf pkg-config-\*
> This did remove pkg-config and replace it with pkgconf, like I expected it to
> do 3-4 days ago and didn't.
> -Mike
I had about the same issues on a fresh RELENG_9 laptop wih xfce4, 
firefox and thunderbird. Just removing pkg-config (pkg_delete -f) then 
installing pkgconf and do a portmaster --check-depends solved it for me.


More information about the freebsd-questions mailing list