Problem with pkgconf and glib.

Jeff Tipton jeff.t at
Mon Jul 30 17:21:25 UTC 2012

On 07/30/2012 19:46, Bas Smeelen wrote:
> On 07/30/12 18:21, Michael Powell wrote:
>> Jeff Tipton wrote:
>>> On 07/30/2012 17:19, Christopher Hilton wrote:
>>>> I'm trying to build emacs with gtk2 on my build box and I'm running 
>>>> into
>>>> trouble with pkgconf from /usr/ports/devel/pkgconf. The build process
>>>> dies in devel/gobject-introspection and complains that it cannot find
>>>> header files for gio-unix-2.0. From what I can see the problem 
>>>> looks like
>>>> the fact that pkgconf is returning the wrong include path for these
>>>> header files, running:
>> [snip]
>>> I have the same problem with devel/gobject-introspection. It's also a
>>> dependecy for Xorg.
>>> A couple of days ago devel/pkg-config was removed from ports as
>>> deprecated, and replaced with devel/pkgconf, and consequently the build
>>> dependencies of many ports were changed. Maybe this recent change is 
>>> not
>>> thoroughly worked out?
>> When I first saw it in UPDATING and did the command I believe it was not
>> completely correct, as it did nothing. That was something on the 
>> order of 3
>> or 4 days ago. Just csup'd today and the command in UPDATING I think
>> contained something slightly different, and is now correct.
>> Before, it did not remove/replace pkg-config. Today it did. Perhaps a 
>> ports
>> tree refresh and if using portupgrade do this:
>> portupgrade -fo devel/pkgconf pkg-config-\*
>> This did remove pkg-config and replace it with pkgconf, like I 
>> expected it to
>> do 3-4 days ago and didn't.
>> -Mike
> I had about the same issues on a fresh RELENG_9 laptop wih xfce4, 
> firefox and thunderbird. Just removing pkg-config (pkg_delete -f) then 
> installing pkgconf and do a portmaster --check-depends solved it for me.
> Disclaimer:
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to 
> "freebsd-questions-unsubscribe at"
Yes, but try now to rebuild X, or emacs (as Christopher). For me, it 
dies at devel/gobject-introspection with the following:

GISCAN GLib-2.0.gir
g-ir-scanner: GLib: warning: 484 warnings suppressed (use --warn-all to 
see them)
   GISCAN GObject-2.0.gir
g-ir-scanner: GObject: warning: 27 warnings suppressed (use --warn-all 
to see them)
   GISCAN GModule-2.0.gir
g-ir-scanner: GModule: warning: 1 warnings suppressed (use --warn-all to 
see them)
gmake[2]: *** No rule to make target 
needed by `Gio-2.0.gir'.  Stop.
gmake[2]: Leaving directory 
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory 
gmake: *** [all] Error 2
*** Error code 1

I don't know what to do with this, I'm already considering ports downgrade.


More information about the freebsd-questions mailing list