firefox 4 pkg_add -r and port error ``TEST-UNEXPECTED-FAIL | | Exited with code 1 during test run''

Antonio Olivares olivares14031 at
Mon May 9 17:42:45 UTC 2011

On Mon, May 9, 2011 at 12:31 PM, Antonio Olivares
<olivares14031 at> wrote:
> Dear folks,
> On my system that I have updated to 8.2-RELEASE-amd64 I get mistake if I try to
> # pkg_add -r firefox
> pkg_add:  package 'perl-5.10.1_3.tbz... Done.
> pkg_add:  package 'perl-5.10.1_3.tbz conflicts with perl-5.12.3
> pkg_add:  please use pkg_delete first to remove conflicting package(s)
> or -f to force installation
> pkg_add:  pkg_add of dependency 'perl-5.10.1_3' failed!
> I then cd'd to /usr/ports/www/firefox and ran
> # make install clean
> and encountered a similar error to
> INFO | | Application pid: 51999
> Error: cannot open display: localhost:1001
> TEST-UNEXPECTED-FAIL | | Exited with code 1 during test run
> INFO | | Application ran for: 0:00:00.514949
> INFO | | Reading PID log: /usr/tmp/tmpQW8cK8pidlog
> gmake: *** [profiledbuild] Error 1
> *** Error code 1
> found in
> and
> I have run make config and disabled the option WITH_PGO I have
> unchecked it and trying again to see if it is building.  If this
> fails, I will ask for help or if it succeeds post a Solved message :)
> Regards,
> Antonio

SOLVED!!! :)


SMB issues:
Network group, machine, and share browsing does not work correctly.

Only sftp access using public key authentication works.  To easily
setup public key authentication to "remote_host":

ssh-keygen -t dsa
cat ~/.ssh/ | ssh remote_host "cat >> .ssh/authorized_keys"

The SSH server on remote_host must allow pub key authentication.


Firefox 4.0 and HTML5

Certain functions used to display HTML5 elements need the sem module.

If your Firefox crashes with the following message while viewing a
HTML5 page:
"Bad system call (core dumped)"

you need to load the sem module (kldload sem).

To load sem on every boot put the following into your


Any bug reports should be addressed to the maintainers at:
	gecko at
You may also Cc: freebsd-ports at Please do not send
bug reports to any other addresses.

Please include the following information with any bug report:
* Output from 'uname -a'.
* Output from 'ident /usr/ports/www/firefox/Makefile'
* Where/when did the problem occur: configuring, building, or
	running firefox
* How can you reproduce the problem?

Thank you for your help in testing and reporting bugs, and we hope you
enjoy using Firefox.
The Maintainers (gecko@)
===>   Registering installation for firefox-4.0.1,1
===>  Cleaning for firefox-4.0.1,1

[olivares at grullahighschool ~]$ uname -a
#0: Thu Feb 17 02:41:51 UTC 2011
root at  amd64

Sorry for the noise :(



More information about the freebsd-questions mailing list