Can't open serial line /dev/cuaa0: no such file or direcotry (2)

Greg 'groggy' Lehey grog at
Sun Jan 23 23:25:26 UTC 2011

[format recovered]

On Friday, 21 January 2011 at  0:04:12 +0000, Mike Adams wrote:
> To whom it may concern: I'm using a programme called tempcontrol
> from Greg Lehey on a Dell pentium running BSD 6.

Do you mean FreeBSD 6.x?  I'm assuming so in the following.

> When I run the programme, I get the above error.  ls /dev shows that
> there is no cuaa0, only cuad0.  I see that this was changed to
> standardize naming conventions.  I've tried sh makedev cuaa0, but
> get the errorCan't open makedev: no such file or directory.

makedev is obsolete.

> I should be most grateful if someone can get me over this problem

The device you're looking for is either /dev/ttyd0 or (probably)
/dev/cuad0.  Quite possibly either would work.  Set it in your
temperaturecontrolrc file.  Let me know if it works, and I'll update
the sources.

On Friday, 21 January 2011 at 12:51:25 +0100, Polytropon wrote:
> On Fri, 21 Jan 2011 00:04:12 +0000, Mike Adams <mike.adams2009 at> wrote:
>> I've tried sh makedev cuaa0, but get the errorCan't open
>> makedev: no such file or directory.
> I think "sh MAKEDEV" would be the correct call.

From MAKEDEV(8):

     The MAKEDEV script was deprecated by devfs(5) and removed from FreeBSD
     after devfs(5) became mandatory.

Basically, it can't work because the meaning of major and minor
numbers has changed.

> You could try to add a line like
> 	link	cuad0	cuaa0
> to /etc/devfs.conf and then
> 	# /etc/rc.d/devfs restart

That would be the wrong solution.  Programs that come in source can be
modified, and in this case the program provides for alternative device

> but I may be possible that the program you're intending to use does
> require the "conventional" serial driver ...

I'm not aware of any such program.

When replying to this message, please copy the original recipients.
If you don't, I may ignore the reply or reply to the original recipients.
For more information, see
See complete headers for address and phone numbers.
This message is digitally signed.  See for more details.
If your Microsoft MUA reports problems, please read
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list