Can't open serial line /dev/cuaa0: no such file or direcotry (2)

Michael Adams mike.adams2009 at
Tue Jan 25 10:35:18 UTC 2011

Dear Greg,

Thanks for your reply.  I've avoided contacting you because I've been "doing
my homework" in an attempt to get up to speed.  However, I'm delighted to
hear from you, and must congratulate you on your work with Tempcontrol.

In fact, I've overcome the problem with port nomenclature in exactly the way
you suggested, and the error no longer appears.  I simply changed the value
in .temperaturecontrolrc to /dev/cuad0.

I do, however, have other problems with the programme: regardless of the
values that I pass to endtemp, none of the solenoids are responding and I
get no output on screen.

May I discuss this with you further?  Your program seems to be precisely
what I need, but unlike you, my problem in chilly East Anglia is keeping the
fermentation temperature up, not down, for most of the year!


Michael Adams

On 23 January 2011 23:08, Greg 'groggy' Lehey <grog at> wrote:

> [format recovered]
> On Friday, 21 January 2011 at  0:04:12 +0000, Mike Adams wrote:
> > To whom it may concern: I'm using a programme called tempcontrol
> > from Greg Lehey on a Dell pentium running BSD 6.
> Do you mean FreeBSD 6.x?  I'm assuming so in the following.

FreeBSD 7.3 now.

> > When I run the programme, I get the above error.  ls /dev shows that
> > there is no cuaa0, only cuad0.  I see that this was changed to
> > standardize naming conventions.  I've tried sh makedev cuaa0, but
> > get the errorCan't open makedev: no such file or directory.
> makedev is obsolete.
> > I should be most grateful if someone can get me over this problem
> The device you're looking for is either /dev/ttyd0 or (probably)
> /dev/cuad0.  Quite possibly either would work.  Set it in your
> temperaturecontrolrc file.  Let me know if it works, and I'll update
> the sources.
> On Friday, 21 January 2011 at 12:51:25 +0100, Polytropon wrote:
> > On Fri, 21 Jan 2011 00:04:12 +0000, Mike Adams <mike.adams2009 at>
> wrote:
> >
> >> I've tried sh makedev cuaa0, but get the errorCan't open
> >> makedev: no such file or directory.
> >
> > I think "sh MAKEDEV" would be the correct call.
> From MAKEDEV(8):
>     The MAKEDEV script was deprecated by devfs(5) and removed from FreeBSD
>     after devfs(5) became mandatory.
> Basically, it can't work because the meaning of major and minor
> numbers has changed.
> > You could try to add a line like
> >
> >       link    cuad0   cuaa0
> >
> > to /etc/devfs.conf and then
> >
> >       # /etc/rc.d/devfs restart
> That would be the wrong solution.  Programs that come in source can be
> modified, and in this case the program provides for alternative device
> names.
> > but I may be possible that the program you're intending to use does
> > require the "conventional" serial driver ...
> I'm not aware of any such program.
> Greg
> --
> When replying to this message, please copy the original recipients.
> If you don't, I may ignore the reply or reply to the original recipients.
> For more information, see
> See complete headers for address and phone numbers.
> This message is digitally signed.  See
> for more details.
> If your Microsoft MUA reports problems, please read

More information about the freebsd-questions mailing list