problems mounting android htc

Fernando Apesteguía fernando.apesteguia at
Mon Jan 17 11:00:54 UTC 2011

On Sun, Jan 16, 2011 at 3:36 PM, Chris Brennan <xaero at> wrote:
> On Sat, Jan 15, 2011 at 8:27 PM, Patrick Lamaiziere
> <patfbsd at>wrote:
>> Le Sat, 15 Jan 2011 18:57:33 -0500,
>> Aryeh Friedman <aryeh.friedman at> a écrit :
>> > No idea how but when I plug the USB in it says "USB Debugging
>> > Connected"
>> On my HTC dream when I connect it to USB, there is a notification on the
>> phone and I have (on the phone) to "unmount" the sd card.
>> Then I can mount the sd card from FreeBSD with
>> mount_msdosfs /dev/da0s1 /mnt
>> dmesg:
>> ugen2.2: <HTC> at usbus2
>> umass0: <HTC Android Phone, class 0/0, rev 1.02/1.00, addr 2> on usbus2
>> umass0:  SCSI over Bulk-Only; quirks = 0x0000
>> umass0:3:0:-1: Attached to scbus3
>> (probe0:umass-sim0:0:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0
>> (probe0:umass-sim0:0:0:0): CAM status: SCSI Status Error
>> (probe0:umass-sim0:0:0:0): SCSI status: Check Condition
>> (probe0:umass-sim0:0:0:0): SCSI sense: UNIT ATTENTION asc:29,0 (Power
>> on, reset, or bus device reset occurred) (probe0:umass-sim0:0:0:0):
>> TEST UNIT READY. CDB: 0 0 0 0 0 0 (probe0:umass-sim0:0:0:0): CAM
>> status: SCSI Status Error (probe0:umass-sim0:0:0:0): SCSI status: Check
>> Condition (probe0:umass-sim0:0:0:0): SCSI sense: NOT READY asc:3a,0
>> (Medium not present) da0 at umass-sim0 bus 0 scbus3 target 0 lun 0
>> da0: <HTC Android Phone 0100> Removable Direct Access SCSI-2 device
>> da0: 40.000MB/s transfers
>> da0: Attempt to query device size failed: NOT READY, Medium not present
>> GEOM: da0: partition 1 does not start on a track boundary.
>> GEOM: da0: partition 1 does not end on a track boundary.
> I had a similar problem a weeks ago (posted to this list) with my LG Vortex.
> It refused to mount (da0 would get assigned and then immediately removed).
> If I left it plugged in for some undetermined time it worked. I would be
> able to mount it normally on fbsd7.3/fbsd8.1/fbsd8.2/fbsd9.0 without issue.
> I suspect it might be something in the Linux Kernel running on the phone but
> have not rooted it (and honestly don't intend to right now).

I had the same problem: da4 created and immediately removed. I tried to leave it
plugged but nothing changed. I assume some event is eventually
triggered in your case so
somehow the device gets recognized.
What does dmesg say?


> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list