hoope THIS works...

Gary Kline kline at thought.org
Thu Mar 25 08:18:28 UTC 2010

On Thu, Mar 25, 2010 at 10:00:05AM +0700, Olivier Nicole wrote:
> > for reasons that are beyond me,  a few hours ago i stopped being able to
> > connect with my mail server.   mutt tells me "(connection refused)";
> > the other GUI mailer say zip; they simply do not connect.
> > 
> > i rebooted my HUB among other things; before that, i could not get outside my 
> > network; nor could i even get to ethic [my Server].  since the only thing i
> > did was powercycle my linksys hub, i figure that did it.
> > 
> > right now i am continuing the portupgrade on my mail/web/dns server in 
> > the hopes that when that is done, mail will work again.  if not, what else
> > could it be?  directories/files/links i need to check/?
> It seems the reboot of your Linksys switch helped some how.

	yes; and it seems likely that the reason ii could not get to
	my email was that {for unknown reasons} my dovecot has failed
	to initialize.

	note that i did not configure my new setup like this.  now i
	have one mail server and dovecot is used to distribute mail
	to my other unix servers.  i barely understand sendmail; i
	do NOT understand dovecot... . 
> Before portupgrading randomly this or that application, you should try
> to understand what is going wrong.
> Upgrade of DNS should go easily, but when you start upgrading web or
> mail, you are talking about tens or hunderds of applications, you are
> very likely something goes wrong and you break a system that was
> working before.

	it seems that mail my daughter sent me from hotmail did not
	pass muster because it lacked a subject.  i was advised to
	portupgrade {or at least upgrade my spamblocker}.  i did
	this.  during the upgrade of either dovecot or spamassassin i
	was asked to kill one or both.  i figured a reboot would
	reinstantiate everything.  it may have; but things were not 
	restarted correctly.  

	bind9 is current; i am extremely careful with that; i just
	didn't realize that i've got to approach everything with the
	same caution.

> When you say you could not "get" to ethic, what do you mean?
> - Cannot ping?
> - Cannot ssh?
> - Cannot telnet port 22, 25, 80?
> - Cannot traceroute (if your station and the server are on different
>   LAN)?
> - Cannot ping another machine on your LAN?
> - Are you sure it was not your desktop that was faulty?

	my firewall was the give-away.  i run pfSense and it told me
	that the host was down.  

	the real gotcha is that my KVM wires are not plugged in
	correctly.   so i could not even get to the serve until i
	messed with that.  when i was able to type at the console 
	of my server, i did a therapeutic reboot.   ---altho, the was
	power-cycling my switch that really did the trick.

	i was about to call it a century when i tried mail.  mutt
	failed again; that turned out to be that dovecot had failed
	to restart.

	Now everything is working.  but it's only temporary.  back in
	the mid-90s a systems admin friend said that
	computers/networks/<<things>>  are always breaking
	down.  it's the sysadmin's job to do his best to keep things
	going.  i get an F- for that today/tonight.....   FWIW, i
	don't even pretend to be a syste,s admin!

> - Etc.
> You should make a diagnostic before trying to apply any solution.
> As the reboot of thw switch did it, to me it looks like a network
> issue: bad switch, bad cable, some highly infected machine on your LAN
> that is stressing the swtich, rather than a server/service issue.

	the power line was bent to the switch; but not that badly.
	[[i'm keeping a Printed list of things-to-do-before-i-hit-PANIC.]]

	appreciate your mail!


> Good luck,
> Olivier
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"

 Gary Kline  kline at thought.org  http://www.thought.org  Public Service Unix
        http://jottings.thought.org   http://transfinite.thought.org
    The 7.79a release of Jottings: http://jottings.thought.org/index.php

More information about the freebsd-questions mailing list