Andy Hiscock andyjhiscock at yahoo.com
Thu Jun 3 19:10:35 UTC 2010

After being advised to upgrade after a freebsd-update I have successfully upgraded from 7.2 to 8.0-p3. OK but have come across a major problem for me.

OK time for a BIG rant this has been going on for 2 days (very sorry)

After the install of the new kernel Samba isn't working.   I TTL's onto the server and tried a testparm but the error messages suggest I have dependancies missing?! - surely this should be taken into account when upgrading versions - Major schoolboy error on FreeBSD when Linux can do this basic task seamlessly!

OK I try sysinstall and find SAMBA isn't marked as installed.  I select samba for install but when installing SAMBA get a error code -1 (WTF is that all about REALLY USEFUL error message mate!)

Looked on google and keeps referring to PORTS being installed.  Tried the examples of how to install SAMBA but get loads of failed command line instructions - Doesn't say anything about installing "PORTS" during initial installation.  So I guess you can say I don't have "Ports" installed - why isn't this done automatically if its absolutely so critical for the OS to function right?  Error messages that mean nothing to the every day user.   Apparently I am meant to have something called PORTS installed before I've even setup the server.  Im really beginning to lose my rag with this OS.  Is it meant for gurus only?

So what am I meant to do now.  Now I have XXX GB of data I cant access though SAMBA prior to the install?


More information about the freebsd-questions mailing list