Tijl Coosemans tijl at
Mon Jan 4 15:59:15 UTC 2010

On Monday 04 January 2010 15:28:03 gianrico.lamura at wrote:
> On Mon, 4 Jan 2010 15:12:35 +0100, Tijl Coosemans
> <tijl at> wrote:
>> On Monday 04 January 2010 13:27:06 gianrico.lamura at
>> wrote:
>>> to install MATLAB i have followed striclty what FreeBSD doc
>>> suggests (even if this doc is not updateed and contains erros) @
>>> To avoid the "SSE2" problem I followed:
>>> to run succesfully the installation. But, at the end of the
>>> installation, when I have to activate the licence, the systems
>>> diplay an error that is explained in the /tem/aws.log file as :
>>> "(Jan 04, 2010 12:58:48)There was an unexpected exception.  See the
>>> log file (/tmp/aws.log) for more details.
>>> (Jan 04, 2010 12:58:56)java.lang.UnsatisfiedLinkError:
>>> /usr/compat/linux/usr/local/matlab/bin/glnx86/
>>> cannot handle TLS data " (**)
>>> and the system stops!!
>>> I tried to run anyway the matlab script but an erro occurred for
>>> the sam reason of SSE2 check. Thus I corrected it by following :
>>> the program starts with the licence request but the same problem as
>>> in (**) still diplays.
>>> I have searched for several days in the net for a solution but I
>>> found nothing. I'm desperate because I need matlab. I have the
>>> licence. I run it before on the same laptop. I changed to FreeBsd
>>> since Ubuntu was too bad for my Philips Freevents X59. But now I do
>>> not know how to solve this problem.
>>> Please, could you help me before I will forced to change another
>>> time the operating system?
>> What version of FreeBSD and Matlab do you use?
> for FreeBSD: 7.2  and Kde 3.5 (all integrated in FreeDesktopSD)
> matlab 2008a

In that case I suspect you have to enable the newer linux compat layer.
The default in FreeBSD 7.2 doesn't support TLS (the (**) error above).

To do this, do the following:

* Remove Matlab and all linux* ports you have installed.
pkg_delete linux\*
* Add this line to /etc/sysctl.conf:
* Matlab probably also needs linprocfs mounted, so add this line to
  /etc/fstab if it isn't there yet:
linprocfs	/compat/linux/proc	linprocfs	rw	0	0
* Reboot.
* Add these two lines to /etc/make.conf:
* Install emulators/linux_base-f10.
* Install f10 versions of the linux* ports if you need them,
  e.g. instead of graphics/linux-png install graphics/linux-f10-png
  if you need it.
* Install Matlab.

You'll still have the SSE2 error, but the TLS error should be gone.

More information about the freebsd-questions mailing list