Making installworld got stuck on SunFire v20z (Freebsd 8.0)

Ivan Voras ivoras at
Sun Feb 21 02:06:08 UTC 2010

Lucas Wang wrote:
> I tried to install Freebsd 8.0 on one of our lab machines, which is
> SunFire v20z. After successfully installing it from CD, I followed the
> following steps trying to update the kernel and world:
> cvsup
> make buildworld
> make buildkernel
> make installkernel
> reboot
> mergemaster -p
> make installworld
> Everything was fine until the `make installworld` process run for a while and then got stuck, 
> after that it won't respond to Ctrl-C. When I tried to login from another tty, it 
> doesn't respond either. I even tried installing the machine from scratch
> several times, and at different times it got stuck when installing different libraries. 
> I would really appreciate any ideas about why this could happen or how
> to solve it.

If you have an AMD CPU of a recent generation, Try adding


to /boot/loader.conf and rebooting. This disables Superpages - there is 
a CPU bug on some of those.

More information about the freebsd-questions mailing list