Making installworld got stuck on SunFire v20z (Freebsd 8.0)

Randy Schultz schulra at
Fri Feb 19 13:24:23 UTC 2010

On Thu, 18 Feb 2010, Lucas Wang spaketh thusly:

-}I tried to install Freebsd 8.0 on one of our lab machines, which is
-}SunFire v20z. After successfully installing it from CD, I followed the
-}following steps trying to update the kernel and world:
-}make buildworld
-}make buildkernel
-}make installkernel
-}mergemaster -p
-}make installworld
-}Everything was fine until the `make installworld` process run for a while and then got stuck, 
-}after that it won't respond to Ctrl-C. When I tried to login from another tty, it 
-}doesn't respond either. I even tried installing the machine from scratch
-}several times, and at different times it got stuck when installing different libraries. 

Hard tellin'.  When you tried to install from scratch, did you keep the same
partitions and not force a newfs?  When you rebooted, did you reboot into

The steps that have never failed me are close to what you have:
   - csup
   - env -i make buildworld
   - env -i make buildkernel
   - env -i make installkernel
   - reboot into single user
   - mount -a
   - mergemaster -paU
   - make installworld
   - mergemaster -aU
   - reboot

Perhaps try a re-install but fiddle a bit with the partition sizes and/or
force a newfs of the partitions.  Also, at the install step where you select
the entire drive (assuming this is what you are doing), you can delete what's
there and re-select "use the entire drive".  That also forces newfs'ing.


 Randy    (schulra at      765.983.1283         <*>

Love with your heart, think with your head;  not the other way around.

More information about the freebsd-questions mailing list