Canon printer and TurboPrint

Jerry gesbbb at
Sun May 24 14:46:22 UTC 2009

On Sat, 23 May 2009 09:10:53 -0700 (PDT)
"kristian.tenorio" <kristian.tenorio at> wrote:

>Well, you have a Canon iP8500.  I guess I can really help you.
>I have tried TurboPrint on FreeBSD and it works.  Here is what I did:
>0) I installed the Fedora linux compat package from my FreeBSD discs
>1) I enabled the linux compatibility by adding as root the following
>line to /etc/rc.conf
>2) I installed bash and symlinked it to /bin by running as root
>cd /bin ; ln -s `which bash`
>3) I installed ghostscript, you probably have it installed already
>4) I mounted as root the linprocfs by running
>mount -t linprocfs linprocfs /compat/linux/proc
>5) I downloaded the .tgz Turboprint file, copied it to my home and
>untarred it using
>where MYTURBOPRINTFILE is the name of the file you downloaded ending
>in .tgz 6) I changed to the new folder and ran as root this, following
>the on-screen instructions
>brandelf -t 'Linux' setup
>cd /compat/linux/usr/bin
>ls t*
>7) With this last command you see some new programs installed from the
>Turboprint setup like
>tpprint, turboprint, etc.  You simply change its brand, as root of
>course by running on each of them
>brandelf -t 'Linux' TURBOPRINT-BINARY
>where TURBOPRINT-BINARY is the name of each executable file you think
>is Turboprint's.
>8) Now is time to do the script.  Enter your text editor on your
>session, copy the following
>script AS IS and save it as tpr on your home directory. Notice the P=
>and D= fields.
>if [ $1 ]; then S=$1 ; else S=- ; fi
>gs -sDEVICE=pcx24b -dBATCH -dNOPAUSE -dTextAlphaBits=4
>-dGraphicsAlphaBits=2 \
>-dMaxBitmap=10000000 -sOutputFile=$HOME/tpr.pcx $S
>$F -d$P $HOME/tpr.pcx $HOME/tpr.job ; rm $HOME/tpr.pcx
>cat $HOME/tpr.job >$D ; rm $HOME/tpr.job
>9) Make it executable and copy it to /usr/local/bin as root, something
>like cd /home/YOUR_USERNAME
>chmod 555 tpr
>cp tpr /usr/local/bin
>Now, it is installed. When you want to print follow these steps.
>Remember, you have to do this every time you turn your printer on.
>1) Turn on your printer
>2) Run the following command as root
>chmod 666 /dev/ulpt0
>This will allow every user in the system print.
>3) Go to the File menu in your app and select Print as you'd always do
>4) If it is KDE, click Advanced Options and select (generic) from the
>menu. If it's not KDE look for printing through a command.  The idea
>here is to print using a command.
>5) Look for the command field and type tpr
>6) Click OK or whatever else in your program and it will print your job
>You can print also a PDF or PostScript file on your terminal (it all)
>by running
>It works on whatever printer.  If you have another printer simply
>change the P= field in the script.
>For instance, I have it P=Canon_i250 since I have a Canon i250 USB
>printer installed at home.
>If it doesn't work maybe the device is wrong.  If the /dev/ulpt0
>doesn't work, try /dev/unlpt0 if USB,
>or /dev/lpt0 for Parallel's.  That is set in the D= field.  /dev/ulpt0
>should work for USB Printers.
>Send me an email.  I really want to know whether it does work for you
>or not.
>Here it is, kristian.tenorio at
>Chandan Haldar wrote:
>> Couldn't fix it with the time I could spend... so still saving
>> printouts for
>> Windoz.  :-(  I know, I know, it's a shame...
>> On 12/8/06, a at <a at> wrote:
>>> On Thu, Jun 29, 2006 at 08:59:51PM +0530, Chandan Haldar wrote:
>>> > I'm searching for ways to print on a Canon PIXMA IP8500
>>> > from FreeBSD 6.0 Release.
>>> >
>>> > Has anyone tried to make the linux driver for PIXUS IP 8600
>>> > from work for the PIXMA IP 8500 on FreeBSD?
>>> >
>>> > Has anyone tried the TurboPrint linux driver on FreeBSD?
>>> > I need it bad enough to even buy this Euro 30 driver if
>>> > it works on FreeBSD.
>>> >
>>> > It's incredibly annoying to have to boot Win just to print
>>> > :-(.
>>> >
>>> > Chandan
>>> How do you print on your Canon PIXMA?
>>> I have a Canon PIXMA iP 2000 and the same problem.
>>> Elisej Babenko

Seriously, before I spent all that time and trouble, I would just use a
Windows PC. Then again, that is just my 2¢.

gesbbb at

A friend of mine won't get a divorce, because he hates
lawyers more than he hates his wife.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list