PS/2 mice suddenly stopped working

Dmitry RCL Rekman dmitry.rekman at
Sat Mar 22 12:24:27 PDT 2008


On Sat, Mar 22, 2008 at 6:02 PM, Greg Mars <authentec at> wrote:

> I just turned on today and my ps/2 mouse (actually SB with a ps/2 adapter)
> was not working.
> Tried reconfiguring in sysinstall to no avail.
> Tried another pure ps/2 mouse and it didn't work either.
> Took off the usb-ps/2 adapter off the original mouse, plugged it in a usb
> port, and now it works.
> Everything used to work just the day before.
> I guess it's possible something could be wrong with the  port
> (which would be sad since the motherboard is probably 2-3 weeks old)
> Does anyone have any ideas on how to test this?
> I don't have another OS on this box and installing one won't be easy.

I used to have similar problem once - PS/2 (real PS/2, not one with an USB
adapter) mouse got stuck every time it was left inactive for more than 5
minutes or so. I sort of "cured" it by restarting moused every 5 minutes
with a cron job - so next time you may also try restarting moused before
unplugging the mouse.

By no means it is meant to be correct solution, I am just suggesting you to
check whether the problem is caused by software or hardware.

Best regards,
Dmitry RCL Rekman

More information about the freebsd-questions mailing list