Having problems with my ports configuration

Patrick Mahan mahan at mahan.org
Fri Feb 29 21:03:38 UTC 2008

System Info:

   Compaq Presario (AMD Athlon CPU)
   256 Mbytes RAM
   80 Gig IDE system disk
   FreeBSD 5.5-RELEASE #0: Tue May 23 14:58:27 UTC 2006

I am having problems with my current installed ports.  Last week
the drive where /usr/ports is upon (80 Gig IDE) start generating
READ errors on the console and hanging the system.  It took a few
days of doing multiple reboots, fsck and BIOS work before it was
back operating again.

One of the issues that came out of this was it seemed that the
ports database (/var/db/pkg/pkgdb.db) was corrupt.  So I tried
to rebuild it by deleting it and setting PKG_DBDIR).  I issued
a 'portsdb -Uu' and it fails -

host# portsdb -Uu
Updating the ports index ... Generating INDEX.tmp - please 
"/usr/ports/japanese/p5-DateTime-Calendar-Japanese-Era" non-existent -- 
dependency list incomplete
===> devel/p5-DateTime-Calendar-Japanese failed
*** Error code 1
1 error

I've tried fetching a new INDEX, done a pkgdb -Fu, but nothing seems to

Also, 'pkg_info' gives "no packages installed" and portversion gives
"** No matching package found: *".

So, somehow, I have managed to seriously hammer my ports/package
installation.  Is there a way to recover this info?  Is there any
way of determing just what is installed (I know of a few: Perl,
emacs, etc) from info stored under '/usr/ports'?

I've looked through the web and the archives and cannot seem to
find a similar type of problem.



More information about the freebsd-questions mailing list