Having problems with my ports configuration

Mel fbsd.questions at rachie.is-a-geek.net
Fri Feb 29 21:57:06 UTC 2008

On Friday 29 February 2008 21:25:06 Patrick Mahan wrote:
> System Info:
>    Compaq Presario (AMD Athlon CPU)
>    256 Mbytes RAM
>    80 Gig IDE system disk
>    FreeBSD 5.5-RELEASE #0: Tue May 23 14:58:27 UTC 2006
> I am having problems with my current installed ports.  Last week
> the drive where /usr/ports is upon (80 Gig IDE) start generating
> READ errors on the console and hanging the system.  It took a few
> days of doing multiple reboots, fsck and BIOS work before it was
> back operating again.
> One of the issues that came out of this was it seemed that the
> ports database (/var/db/pkg/pkgdb.db) was corrupt.  So I tried
> to rebuild it by deleting it and setting PKG_DBDIR).  I issued
> a 'portsdb -Uu' and it fails -

You're confusing .db's here. /vardb/pkg/pkgdb.db is fixed or rebuilt, using 
pkgdb -F. But read on...

> host# portsdb -Uu
> Updating the ports index ... Generating INDEX.tmp - please
> wait..p5-DateTime-Calendar-Japanese-0.06001:
> "/usr/ports/japanese/p5-DateTime-Calendar-Japanese-Era" non-existent --
> dependency list incomplete
> ===> devel/p5-DateTime-Calendar-Japanese failed
> *** Error code 1
> 1 error

You're missing that directory, fsck probably deleted it. If you wanted to keep 
your old ports tree, you're outof luck without having a backup.
csup -L2 /path/to/ports-supfile

Or use portsnap, or whatever you're comfy with.

> I've tried fetching a new INDEX, done a pkgdb -Fu, but nothing seems to
> work.

pkgdb -F does nothing? No errors, warnings? Could be your /var/db/pkg is 
damaged as well, if it's the same disk.


Problem with today's modular software: they start with the modules
    and never get to the software part.

More information about the freebsd-questions mailing list