/bin/csh script in GELI partition crashes 6.3-STABLE

Scott Bennett bennett at cs.niu.edu
Tue Feb 12 21:47:38 UTC 2008

     On Tue, 12 Feb 2008 16:01:26 +0100 Roland Smith <rsmith at xs4all.nl>
>On Tue, Feb 12, 2008 at 08:02:49AM -0600, Scott Bennett wrote:
>>      I just set up a GELI partition for the first time a while ago (not
>> counting the swap partition).  After initializing the GELI device file,
>> filling it from /dev/random, running newfs, and copying over a couple of
>> directory trees from another file system, I tried running a C-shell script
>> in one of the bottom-level directories.  The script works fine in its
>> original location, but after cd'ing to the new location and running it,
>> the system immediately reboots.  Because this leaves most/all of the file
>> systems marked dirty, fsck has to run on startup.  (I ran fsck by hand on
>> the GELI partition.)
>>      It does it every time, so it is certainly repeatable.  Is this a
>> known problem?  Or is there some feature of GELI-encrypted file systems
>> that is expected to have problems running scripts?=20
>My /home is a GELI encrypted partition. I've never had problems running
>scripts from it, although my scripts are usually sh, not csh.=20
>What does the script do? Are you running it as root?
     The script displays a bunch of pictures as separate xv(1) windows.  No,
I was running it under my own userid.  It is quite simple:

% cat show
#! /bin/csh
set delay=2
set pixlist=(09 08 07 05 04 03 02 01)
foreach i ($pixlist)
        (nice xv $i.jpg &)
        sleep $delay

The delay is simply to ensure the windows get opened in the sequence that
I want them opened.  The photos are in the same directory, and I run it by
typing "./show" in the directory.  If I type, for example, "xv 01.jpg&", it
works fine in either the old location or in the GELI partition.  If I type
"./show" in the copy of the directory that is in the GELI partition, FreeBSD
reboots immediately.  When it first happened, I thought maybe the machine
had had some other problem, perhaps thermal, although I thought I'd dealt
with its thermal problems.  After it restarted, I thought nothing of it and
typed "./show" in the directory in the GELI partition again.  It rebooted
on the spot.  I was shocked, to say the least.
     I may do a little more experimenting the next time I decide to shut
down my tor server, but I doubt I will before then because I hate to crash
the system with a server running.
     Maybe I should try GBDE instead of GELI.  I chose GELI for the 
partition in question mainly because I was already using it for the swap
partition, but maybe it's still a little too green to be reliable yet.

                                  Scott Bennett, Comm. ASMELG, CFIAG
* Internet:       bennett at cs.niu.edu                              *
* "A well regulated and disciplined militia, is at all times a good  *
* objection to the introduction of that bane of all free governments *
* -- a standing army."                                               *
*    -- Gov. John Hancock, New York Journal, 28 January 1790         *

More information about the freebsd-questions mailing list