/bin/csh script in GELI partition crashes 6.3-STABLE

Roland Smith rsmith at xs4all.nl
Tue Feb 12 22:51:51 UTC 2008

On Tue, Feb 12, 2008 at 03:46:56PM -0600, Scott Bennett wrote:
>      On Tue, 12 Feb 2008 16:01:26 +0100 Roland Smith <rsmith at xs4all.nl>
> wrote:
> >On Tue, Feb 12, 2008 at 08:02:49AM -0600, Scott Bennett wrote:
> >>      I just set up a GELI partition for the first time a while ago (not
> >> counting the swap partition).  After initializing the GELI device file,
> >> filling it from /dev/random, running newfs, and copying over a couple of
> >> directory trees from another file system, I tried running a C-shell script
> >> in one of the bottom-level directories.  The script works fine in its
> >> original location, but after cd'ing to the new location and running it,
> >> the system immediately reboots.  Because this leaves most/all of the file
> >> systems marked dirty, fsck has to run on startup.  (I ran fsck by hand on
> >> the GELI partition.)
> >>      It does it every time, so it is certainly repeatable.  Is this a
> >> known problem?  Or is there some feature of GELI-encrypted file systems
> >> that is expected to have problems running scripts?=20
> >
> >My /home is a GELI encrypted partition. I've never had problems running
> >scripts from it, although my scripts are usually sh, not csh.
> >
> >What does the script do? Are you running it as root?
> >
>      The script displays a bunch of pictures as separate xv(1) windows.  No,
> I was running it under my own userid.  It is quite simple:
> % cat show
> #! /bin/csh
> set delay=2
> set pixlist=(09 08 07 05 04 03 02 01)
> foreach i ($pixlist)
>         (nice xv $i.jpg &)
>         sleep $delay
> end
> The delay is simply to ensure the windows get opened in the sequence that
> I want them opened.  The photos are in the same directory, and I run it by
> typing "./show" in the directory.  If I type, for example, "xv 01.jpg&", it
> works fine in either the old location or in the GELI partition.  If I type
> "./show" in the copy of the directory that is in the GELI partition, FreeBSD
> reboots immediately. 

I've run your script on a batch of photos on a GELI encrypted partition
without problems. This is on FreeBSD 7.0-PRERELEASE amd64

I would look at the X server. Since it runs as root and has access to
/dev/mem and /dev/io an X bug could potentially screw things up quite nicely.
I'm running xorg-server-1.4_4,1.

If you have it installed, try display(1) from the ImageMagick suite
instead of xv. See if it makes any difference.

I presume you've checked for the obvious things such as out of memory or
filesystem full?

>      Maybe I should try GBDE instead of GELI.  I chose GELI for the 
> partition in question mainly because I was already using it for the swap
> partition, but maybe it's still a little too green to be reliable yet.
I've used it on my /home for years without trouble.

From what I've read, GELI is supposed to be more secure.

R.F.Smith                                   http://www.xs4all.nl/~rsmith/
[plain text _non-HTML_ PGP/GnuPG encrypted/signed email much appreciated]
pgp: 1A2B 477F 9970 BA3C 2914  B7CE 1277 EFB0 C321 A725 (KeyID: C321A725)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20080212/61e44b39/attachment.pgp

More information about the freebsd-questions mailing list