resolver problems

Derek Ragona derek at
Sun Oct 28 17:03:46 PDT 2007

At 06:47 PM 10/28/2007, jekillen wrote:
>I am still having resolver problems with my 6.2 system.
>It has shown up with trying to install ports from the ftp site.
>I discovered that there is no resolv.conf file, so I created one.
>The funny thing is if I ping one of my web sites with
>www.<domainName>.com ping can't resolve the address.
>but if I do <actualHostName>.<domainName>.com it works.
>Just for control test purposes I tried from a Mac OSX machine
>and was able to ping www.<domainName>.com. I even have
>my own DNS servers listed as servers to contact in resolv.conf
>To abbreviate this message, I am trying to get ports set up
>and working.
>This time I tried portsnap fetch and the site indicated as
>the source and mirrors could not be found.
>Any suggestions, help, advice is appreciated. I am going more
>to the existing material, but it obviously cannot anticipate this
>sort of problem literally.
>Thanks In Advance:
>Jeff K

Sounds like a DNS problem.  Make sure your /etc/hosts only defines the 
hostname for that machine and localhost.  Check you have the correct order 
of hosts in /etc/resolv.conf, it is read top down.  Check your 
/etc/nsswitch.conf hosts line which should be:
hosts: files dns

You may by mistake have left an entry in a hosts file, or have your DNS not 
forwarding correctly for unknown names.


>freebsd-questions at mailing list
>To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"
>This message has been scanned for viruses and
>dangerous content by MailScanner, and is
>believed to be clean.
>MailScanner thanks transtec Computers for their support.

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.
MailScanner thanks transtec Computers for their support.

More information about the freebsd-questions mailing list