resolver problems

James oscartheduck at
Sun Oct 28 16:53:33 PDT 2007

On 10/28/07, jekillen <jekillen at> wrote:
> Hello:
> I am still having resolver problems with my 6.2 system.
> It has shown up with trying to install ports from the ftp site.
> I discovered that there is no resolv.conf file, so I created one.
> The funny thing is if I ping one of my web sites with
> www.<domainName>.com ping can't resolve the address.
> but if I do <actualHostName>.<domainName>.com it works.

That's probably because you're pinging them via the internal address, not
the external address. If you've got a little router, it's grabbed the
internal names. If not, then this is interesting, but the same fundamental
idea would seem to hold.

Just for control test purposes I tried from a Mac OSX machine
> and was able to ping www.<domainName>.com. I even have
> my own DNS servers listed as servers to contact in resolv.conf

Okay, did you try setting up the /etc/resolv.conf on the FreeBSD boxes to
match the one on the Mac OS X machine?

It's also possible it's your route tables. But tell me first if you've got a
small home router that you're connecting everything via.

To abbreviate this message, I am trying to get ports set up
> and working.
> This time I tried portsnap fetch and the site indicated as
> the source and mirrors could not be found.
> Any suggestions, help, advice is appreciated. I am going more
> to the existing material, but it obviously cannot anticipate this
> sort of problem literally.
> Thanks In Advance:
> Jeff K
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "
> freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list