rpc_lockd and syslogd

Mel fbsd.questions at rachie.is-a-geek.net
Fri Oct 12 16:06:29 PDT 2007

On Saturday 13 October 2007 00:41:31 mr. phreak wrote:

> I have a chicken-egg problem. On my diskless setup the syslogd gives me
> this error during boot:
> syslogd: cannot open pid file: operation not supported
> And I tracked the issue to flock() and enabled rpc_lockd. Still it gives
> me the same error - because rpc_lockd
> starts AFTER syslogd does. I've tried fiddling around with REQUIRES and
> PROVIDES in the rc.d files but I cannot make it work... It gives me the
> error anyway. (or other errors due to rc.d-hacking)... is there any way
> to solve this? I'd appreciate some help!
> when running syslogd when logged in it doesn't give me the error so I
> guess rpc_lockd *really* is the sollution.

Or the solution is specifying a pid file on a memory disk? I can't think of 
any issues with /var/run being /dev/md*, but there might some. In any case, 
syslogd_flags="-s -P /tmp/syslogd.pid" should work as well. The issue I see 
with that is that /etc/rc.d/syslogd doesn't expose it's pidfile for outside 


More information about the freebsd-questions mailing list