Problem Launching Applications in Gnome

ruggeri at ruggeri at
Thu Mar 8 03:23:18 UTC 2007


I haven't been able to figure this out, and am hoping someone 
has some ideas.  I can't seem to find any previous mention of 
a similar problem, so I hope I'm not missing something 

I run FreeBSD 6.2-STABLE.  I also have installed GNOME 
2.16.3.  I use Gnome-Terminal 2.16.1.

The main application I run is Vim, which I run through Gnome-
Terminal.  I frequently have several copies running 
simultaneously.  In general response to Gnome-Terminal 
commands is very fast, but sometimes when I try to open a 
file with Vim it takes up to 20-30 seconds to load.  The 
files are not particularly large (max 300 lines).

During this time, if I try to launch another application in 
Gnome (e.g., Opera or another Gnome-Terminal), it will not 
come up.  It is as if everything is frozen until finally Vi 
loads and opens the file, at which point anything else I have 
tried to open works fine.

While this loading takes place, I can work in any other open 
application normally.  Oftentimes I have another Vim session 
which I am editing in.

I have of course looked at top when this problem occurs.  CPU 
usage is about 2%, and there is no significant memory usage 

I never experience this problem outside Gnome, whether I'm 
using screen or several virtual terminals.  It's really 

Anyway, I hope someone out there has some ideas.  Thanks very 
much in advance.

-- Ned Ruggeri

PS I'll include my ~/.vimrc file:

set nocompatible
syntax on
set showmatch
set number
set backspace=2
autocmd BufRead *.c set cindent

More information about the freebsd-questions mailing list