CDROM Boot Hangs But Only Under 6.x

Tim Daneliuk tundra at
Tue Dec 25 22:53:19 PST 2007

illoai at wrote:
> On 25/12/2007, Tim Daneliuk <tundra at> wrote:
>> I am building a new server out of both older and brand new
>> components.  It is based on a Pentium D 925 and ABIT LG-95Z
>> mobo.  The DVD-RW is a Lite-On about a year old with very
>> low hours on it.
>> So ... here's a fun one:  I can boot and install FreeBSD 4.x (CD)
>> or Novell SUSE Enterprise Linux Desktop 10 SP1 (DVD) via the
>> DVD.  But attempting to do this with 6.x (I have tried 6.2R and
>> 6.3-PRE disk #1) causes a hang during boot.  The loader gets
>> as far as showing the vertical bar that ordinarily "spins"
>> to show intitial kernel loading progress and the the machine
>> just sits there.  There is some further activity on the optical
>> drive at this point and then the cursor sort of jumps around a bit.
>> I've not yet tried swapping the optical drive out - though I doubt
>> this is the problem since I can load the other OSs.  I've tried
>> removing and moving memory sticks in case this is a flakey
>> memory problem - no change.  I've tried removing the only
>> two cards in the machine: 3COM 905C-TX and an Adaptec 2940UW -
>> no change.
>> I have one last ditch thing I will try later tonight which is
>> to force the DVD IDE port into PIO mode and out of DMA mode.
>> But that's it.  I am stumped.  Ideas anyone?
> If it is not hardware, check your bios settings (and mayhap
> set back to default or very conservative) (of which the PIO
> trick may work).

Well ... no amount of BIOS fiddling fixes this problem.

> Also, 7.0 ran extremely well for me back in Sept., you might
> try it as an alternative.

I downloaded 7.0-BETA4 and burned the CD - This exhibits the
exact same boot time behavior as the earlier 6.x releases.

In summary:

1) I can boot 4.x or Linux install CDs.   I cannot boot 6.x or 7.x
    install CD - system hangs at the beginning of loading the kernel
    and the video cursor starts jumping around - presumably because
    the program has lost its way.  (I am assuming that the "program"
    having trouble is the loader itself, since the kernel is not yet
    loaded at this point.)

2) Changing optical drives made no difference.

3) Reordering/removing memory sticks made no difference.  I am running
    a memory test ATM just to be sure, but so far, the memory seems fine.

4) No amount of poking around in the BIOS settings seems to help either.

I am starting to suspect the MOBO.  If I stick a couple of cards in the
two available PCI slots, the system has trouble taking me into the BIOS
screen.  I have to remove the cards to reliably get into the BIOS
settings menu.  I wonder if this is one of those situations where there
are not enough IRQs to go around.

I remain confused ...

Tim Daneliuk     tundra at
PGP Key:

More information about the freebsd-questions mailing list