Panic on boot

jekillen jekillen at
Sun Dec 16 13:28:33 PST 2007

On Dec 16, 2007, at 7:58 AM, Derek Ragona wrote:

> At 07:32 PM 12/15/2007, jekillen wrote:
>> On Dec 15, 2007, at 5:21 PM, jekillen wrote:
>>> Hello;
>>> I have had an AMD64 754 system that I have 64 bit SCSI card and
>>> two 15k rpm SCSI drives. It has been running fine with FreeBSD v 6.0
>>> for about two years now. I have several things I wanted to change
>>> and reconfigure, software wise, and hardware wise. The first was a 
>>> new
>>> case which I got today. I shut down the system, put everything in 
>>> the new
>>> case and booted. It booted without any complaint. I got the V6.2 
>>> install
>>> cd and put it in. The system froze during boot process after an entry
>>> for mpt 0. I turned off the power and tried rebooting into the 
>>> install cd.
>>> This time it made  it to sysinstall and went through slice and 
>>> partitioning
>>> and was in the process of installing the base system and it froze 
>>> again,
>>> no error messaged to console.  I rebooted and started again. The 
>>> second
>>> time I got all the way through the install process.
>>> Now on reboot the system is panicking just after the line
>>> mtp0 hidden device members(6)
>>> The error is:
>>> Fatal Trap 12 (the screen does not persist
>>> long enough to transcribe it all.)
>>> Three tries, the same thing in the same place in the boot
>>> process.
>> I tried it agian and the same thing happened.
>> This time I got more of the error message.
>> 'page fault while in kernel mode'
>>> does this mean the scsi drives or card is  going bad? (I nope not)
>>> the card is LSI Logic 64 bit card (installed in a standard PCI slot 
>>> but
>>> has been working with an inch of the card hanging off the end
>>> of the slot. I only have one internal bus  available this way, but 
>>> that is
>>> all I need.
>>> Thanks in advance for info
>>> Jeff K
>>> (chewing my fingernails)
> Jeff,
> Could be anything causing this from your "move" such as damaged ram or 
> other component from static or a somewhat flaky power supply in the 
> new case.
> Have you run diagnostics on the hard drives?
> Make sure all your power connectors are tight, no damaged cables.  It 
> is easy with some SCSI cables to damage the cable or connectors, I 
> know I have done that a few times.
> If you can, separate the power to the hard drives to separate lines 
> from the power supply rather than daisy chaining a power line with 
> multiple connectors on it.
> Have you tried other bootable OS's just to see if they crash too?
I was on the verge of panic myself because this machine is my primary 
DNS server.
What I did was reinstall v6.0 to use as a control test and it installed 
without problem and runs without
a problem. It would appear that this combination of hardware does not 
work with FreeBSD 6.2.
I have another machine with a motherboard with PCI X (64 bit) slots and 
the same LSI logic board
installed with v6.2 and it works fine. I am guessing that 6.2 does not 
like the 64 bit SCSI card in a 32 bit
slot. Both are AMD64 processors but the one with v6.0 is using slot 754 
  processor on ECS Elite Group mb,
and the one with v6.2 is using socket AM2 with ASUS M2N32 ws pro mb; 
Perhaps a difference in the mtp driver(?)
Both are home built. Both have been working without problem (accept for 
this latest).
I do plan on getting another ASUS board like the one I have, but that 
is a $300+ board and I have to
get a new processor and ram for it also. So I have to engineer my 
budget for it.
Thanks for the response;
Jeff K

More information about the freebsd-questions mailing list