SSHD errors: will not forward X11 connections

Andrew andrew.chace at
Mon Jun 26 03:05:31 UTC 2006


I have a FreeBSD 6.1 machine at home that I use for remote backups, and
sort of an application server for my home network. I occasionally run
program with the X display forwarded to my laptop. Simple setup, has
always worked great, etc, etc.

Just last week, I went to login and run a program and I received the
following error (in /var/log/messages):

    sshd[25306]: error: Failed to allocate internet-domain X11 display

Now, not to (intentionally) irritate anyone, but I haven't made any
changes in regards to the setup on either end of the connection that I'm
aware of. The only change at all that I've recently made, is that I
switch shells on the remote box (to zsh). I tried changing back to bash,
(my original setup), and the problem persists. 

The permissions for sshd are:

    -r-xr-xr-x  1 root  wheel  168488 May  6 22:58 /usr/sbin/sshd

which looks correct to me. I really haven't a clue where to begin with
this one, besides a backup and re-install, which is an option, but is
also a rather large pain. 



More information about the freebsd-questions mailing list