SSHD errors: will not forward X11 connections

m.apitz at m.apitz at
Mon Jun 26 05:44:32 UTC 2006

El día Sunday, June 25, 2006 a las 10:05:03PM -0500, Andrew escribió:

> Hello,
> I have a FreeBSD 6.1 machine at home that I use for remote backups, and
> sort of an application server for my home network. I occasionally run
> program with the X display forwarded to my laptop. Simple setup, has
> always worked great, etc, etc.
> Just last week, I went to login and run a program and I received the
> following error (in /var/log/messages):
>     sshd[25306]: error: Failed to allocate internet-domain X11 display
>     socket.
> Now, not to (intentionally) irritate anyone, but I haven't made any
> changes in regards to the setup on either end of the connection that I'm
> aware of. The only change at all that I've recently made, is that I
> switch shells on the remote box (to zsh). I tried changing back to bash,
> (my original setup), and the problem persists. 
> The permissions for sshd are:
>     -r-xr-xr-x  1 root  wheel  168488 May  6 22:58 /usr/sbin/sshd
> which looks correct to me. I really haven't a clue where to begin with
> this one, besides a backup and re-install, which is an option, but is
> also a rather large pain. 
> Suggestions?

Truss o strace down the SSH daemon to see what the underlying problem
for "error: Failed to allocate..." really is.

Matthias Apitz
Manager Technical Support - OCLC PICA GmbH
Gruenwalder Weg 28g - 82041 Oberhaching - Germany
t +49-89-61308 351 - f +49-89-61308 399 - m +49-170-4527211
e <m.apitz at> - w

More information about the freebsd-questions mailing list