Please help - adaptec 2820sa not allowing installation

Jahilliya jahilliya at
Mon Jun 19 00:39:26 UTC 2006

On 6/19/06, Ensel Sharon <user at> wrote:
> I did all my due diligence, I contacted freebsd-fs and _made sure_ that
> even though the 2820sa is not listed by name in the HCL, that I could take
> a 6.1-RELEASE cd and install freebsd on a 2820sa.
> I was _assured_ that these cards are supported in 6.1-RELEASE, that all is
> well, and I could install and that was that.
> Now I boot off of the 6.1-RELEASE cd, and sysinstall tells me "no disks
> found".
> I tried safe mode, same result.  I tried disabling all unnecessary items
> from the BIOS (onboard sata, USB, com2, LPT) and same result.
> FreeBSD 6.1-RELEASE iso just does not find a disk controller.  Period.
> So ... what do I do ??  I see no way of adding a driver to sysinstall
> .. .and even if I did I have no idea what to put there, as the published
> driver from adaptec is only for 5.x.
> I have to assume that aac is built into the sysinstall kernel, so what
> gives ?  Why can't sysinstall see my 2820sa cards ? (and drives)

Try hitting scroll lock and then page up to view the dmesg or go to
the emergency console and run dmesg to see if it picked up any aac
devices. You may need to load the module yourself, you should be able
to do this from the emergency console (not sure tho).

I've steered clear of the *20SA series of cards from Adaptec (mainly
buying the 2410SA) for the two facts, SATA2 isn't listed anywhere on
the hardware list and only the xx10SA series SATA cards are listed.

More information about the freebsd-questions mailing list