Problems with pgsql 8.0.4 & freebsd 6: partially solved

Vittorio vdemart1 at
Tue Jan 24 04:47:45 PST 2006

I have been using a postgresql 8.0.4 server under freebsd 5.4 like a 
charm for a long time .
Yesterday, I upgraded freebsd from 5.4 to 6 via 
the CD (the iso was downloaded from

postgresql it happened:

# /usr/local/etc/rc.d/ start
not found
FATAL:  XX000: failed to initialize lc_messages to ""
LOCATION:  InitializeGUCOptions, guc.c:3699

And the server was down

After many attempts I discovered that the problem was connected to the
"setenv LC_ALL it_IT.ISO_8859-1" I had introduced in /usr/local/pgsql/.
which corrupted something in the system and, even removing the 
line, went on failing to start the server

pg_dumped the data before the upgrading to 6, I have solved the problem 
1) eliminating the /usr/local/pgsql/data directory (BY THE WAY, 
remember to backup the pgsql *.conf files somewhere!!);
2) deinstalling 
the postgresql 8.0.4 server by means of "make deinstall";
3) removing 
the pgsql user;
4) reinstalling the postgresql 8.0.4 server;
5) copying 
the *.conf files under the data directory
6) pg_restoring the data

Now, of course I have left unmodified the .cshrc file (take notice that 
any attempt of modyfying the locale corrupts the postgresql server and 
you should start with a new reinstallation! I failed both adding a line 
"setenv LC_ALL it_IT.ISO_8859-1" and "setenv LC_ALL it_IT.ISO8859-1")

Now it all works even though an inoffensive warning comes up

/usr/local/etc/rc.d/ start
--: not found

Is there anything 
else I could do?



More information about the freebsd-questions mailing list