no one here use restore/dump?

Chuck Swiger cswiger at
Thu Jan 19 08:41:02 PST 2006

Wojciech Puchar wrote:
[ ... ]
>> Did you have a more specific question...?
> yes - i did before.
> i have problems with restore. dump is about 60GB and 1.5 million files.
> two problems when doing restore -rvf /device
> 1) after extracting all directory listing it starts to do "Make node..."
> but after some of it done, it starts to take 100% CPU and work for about 
> 1 hour on PII/400 before finishing it.
> eventually it finishes, so it's not such a big problem

If you do a SIGINFO (normally control-T), it ought to give more specific 
information about what it's doing.

Are you restoring to an empty new filesystem which has just been newfs'ed with 
similar inode parameters to the original source of the backup?

> 2) after restoring 7 volumes, at 8-th volume it tried to prepend ? to 
> every pathname extracted so it resulted in error unable to create.
> doing ln -s \? . and restarting restore from 8-th volume worked and i 
> was able to finish things.
> why restore failed? and how to dump without fear!

I haven't seen that sort of problem myself.  Are you sure the original 
filesystem is OK and doesn't contain any weird symlinks which could have 
confused dump?  Try to fsck it and test a new dump/restore sequence.

Did you use the -L flag to dump using a snapshot, that may help...


More information about the freebsd-questions mailing list