mouse dead on FreeBSD but not on Windows

Frank Laszlo laszlof at
Tue Jan 3 09:29:21 PST 2006

> Frank, thanks for your reply,
> this is not just a problem in xorg, it is also the mouse not
> working in the console (without X). I don't get an arrow
> cursor that I can use in the console to copy/paste text.
> I've tried using moused (moused_enable="YES" in rc.conf) and
> then using /dev/sysmouse in xorg.conf and also disabling
> moused and using /dev/psm0 in xorg.conf.
> Identifier  "Mouse1"
> Driver      "mouse"
> Option "Protocol"    "PS/2"
> Option "Device"      "/dev/psm0"
> Option "ZAxisMapping" "4 5"
> (I've done tests with and w/o the ZAxisMapping line, and as
> mentioned with psm0 or sysmouse after /dev/ in the "Device"
> option. None worked).
> When using /dev/psm0 in xorg.conf I got the typical X cursor
> instead of the arrow, and I could move it with the mouse,
> although the movement was erratic ... most of the movement
> of the mouse was not recognized and sometimes the cursor
> would move to the bottom left corner of the screen .... 
> Using moused and /dev/sysmouse in xorg.conf resulted in a
> black arrow as a cursor, as mentioned, but the cursor would
> not move at all. 
> I exchanged the mouse, and now the same setup works (only
> tested the mouse in the console since I'm now rebuilding the
> xorg from ports). This is also a generic mouse (Noganet,
> PS/2) but it has three buttons instead of two and a wheel. 
> Maybe the other mouse is defective, but it works without a
> hitch in WinXP ... or perhaps I'm missing some essential flags
> that need to be added for a wheel mouse?
> Also, I've tried different combinations of ports/types using
> /stand/sysinstall (post-install configurarion->mouse) and I
> never got an arrow shown in the screen when activating the
> mouse daemon with the wheel mouse.
> Fernan
Have you tried starting mouse manually in the foreground? or with
debugging flags? take a look at `man moused` I had a PS/2 mouse, pretty
generic, came up in dmesg as a "4D+" mouse. It would work, but was
jumping all over the screen, worked fine in windows AND interestingly
enough, linux as well. might just be a glitchy implementation, worst
case you gotta pickup another $5 mouse. :)

Frank Laszlo
System Administrator
The VonOstin Group
Email:  laszlof at
Mobile: 248-863-7584

More information about the freebsd-questions mailing list