mouse dead on FreeBSD but not on Windows

Fernan Aguero fernan at
Tue Jan 3 09:15:26 PST 2006

+----[ Frank Laszlo <laszlof at> (03.Jan.2006 12:10):
| Fernan Aguero wrote:
| > Hi!
| >
| > I've a dual boot machine, which was running FreeBSD-5.4 (now
| > 6.0p1) and WinXP. It has a cheap PS/2 mouse (Biswal is the
| > brand, but I guess it's just a generic mouse, details at the
| > bottom).
| >
| > In Windows it works flawlessly ... wheel included. It's been
| > running for months. In FreeBSD it never worked. I don't know
| > if I'm doing something wrong ... this machine is the first
| > box in which I installed 5.x so perhaps there are some
| > configuration differences from 4.x tham I'm unaware of?
| >
| > Any help would be appreciated (of course I can go buy
| > another cheap mouse ... but I'm intrigued now).
| >
| > The details:
| >
| > dmesg says:
| > psm0: <PS/2 Mouse> irq 12 on atkbdc0
| > psm0: [GIANT LOCKED]
| > psm0: model Intellimouse, device ID 3
| >
| > moused says:
| > moused -i all -p /dev/psm0
| > /dev/psm0 ps/2 sysmouse Intellimouse
| >
| > I've tried to run 'vidcontrol -m on' and then 'moused -p
| > /dev/psm0 -t auto/sysmouse' and I never get an arrow on the
| > screen.
| >
| > I've got X installed with gnome and when booting I always
| > get a black arrow in the xdm login screen that I cannot move
| > with the mouse. I also tried to tweak my Xorg.conf file to
| > no avail.
| >
| > My custom kernel has the following (I quote what I guess
| > it's relevant, do ask for more detail if neccessary):
| > device	atkbdc
| > device	atkbd
| > device	psm
| >
| > I just cvsuped against RELENG_6_0 and rebuilt the world and
| > kernel. All the base system is now 6.0p1, and now I need to
| > rebuild all ports ... but apart from that the mouse is still
| > dead on FreeBSD.
| >
| > Again thanks for any help,
| >
| > fernan
| >
| >   
| Are you using moused, or Xorg's mouse daemon? please send the applicable
| section from your xorg.conf. Thanks

Frank, thanks for your reply,

this is not just a problem in xorg, it is also the mouse not
working in the console (without X). I don't get an arrow
cursor that I can use in the console to copy/paste text.

I've tried using moused (moused_enable="YES" in rc.conf) and
then using /dev/sysmouse in xorg.conf and also disabling
moused and using /dev/psm0 in xorg.conf.

Identifier  "Mouse1"
Driver      "mouse"
Option "Protocol"    "PS/2"
Option "Device"      "/dev/psm0"
Option "ZAxisMapping" "4 5"

(I've done tests with and w/o the ZAxisMapping line, and as
mentioned with psm0 or sysmouse after /dev/ in the "Device"
option. None worked).

When using /dev/psm0 in xorg.conf I got the typical X cursor
instead of the arrow, and I could move it with the mouse,
although the movement was erratic ... most of the movement
of the mouse was not recognized and sometimes the cursor
would move to the bottom left corner of the screen .... 

Using moused and /dev/sysmouse in xorg.conf resulted in a
black arrow as a cursor, as mentioned, but the cursor would
not move at all. 

I exchanged the mouse, and now the same setup works (only
tested the mouse in the console since I'm now rebuilding the
xorg from ports). This is also a generic mouse (Noganet,
PS/2) but it has three buttons instead of two and a wheel. 

Maybe the other mouse is defective, but it works without a
hitch in WinXP ... or perhaps I'm missing some essential flags
that need to be added for a wheel mouse?

Also, I've tried different combinations of ports/types using
/stand/sysinstall (post-install configurarion->mouse) and I
never got an arrow shown in the screen when activating the
mouse daemon with the wheel mouse.


More information about the freebsd-questions mailing list