mouse dead on FreeBSD but not on Windows

Frank Laszlo laszlof at
Tue Jan 3 07:05:15 PST 2006

Fernan Aguero wrote:
> Hi!
> I've a dual boot machine, which was running FreeBSD-5.4 (now
> 6.0p1) and WinXP. It has a cheap PS/2 mouse (Biswal is the
> brand, but I guess it's just a generic mouse, details at the
> bottom).
> In Windows it works flawlessly ... wheel included. It's been
> running for months. In FreeBSD it never worked. I don't know
> if I'm doing something wrong ... this machine is the first
> box in which I installed 5.x so perhaps there are some
> configuration differences from 4.x tham I'm unaware of?
> Any help would be appreciated (of course I can go buy
> another cheap mouse ... but I'm intrigued now).
> The details:
> dmesg says:
> psm0: <PS/2 Mouse> irq 12 on atkbdc0
> psm0: [GIANT LOCKED]
> psm0: model Intellimouse, device ID 3
> moused says:
> moused -i all -p /dev/psm0
> /dev/psm0 ps/2 sysmouse Intellimouse
> I've tried to run 'vidcontrol -m on' and then 'moused -p
> /dev/psm0 -t auto/sysmouse' and I never get an arrow on the
> screen.
> I've got X installed with gnome and when booting I always
> get a black arrow in the xdm login screen that I cannot move
> with the mouse. I also tried to tweak my Xorg.conf file to
> no avail.
> My custom kernel has the following (I quote what I guess
> it's relevant, do ask for more detail if neccessary):
> device	atkbdc
> device	atkbd
> device	psm
> I just cvsuped against RELENG_6_0 and rebuilt the world and
> kernel. All the base system is now 6.0p1, and now I need to
> rebuild all ports ... but apart from that the mouse is still
> dead on FreeBSD.
> Again thanks for any help,
> fernan
Are you using moused, or Xorg's mouse daemon? please send the applicable
section from your xorg.conf. Thanks

Frank Laszlo
System Administrator
The VonOstin Group
Email:  laszlof at
Mobile: 248-863-7584

More information about the freebsd-questions mailing list