Problems reading CDRW after writing

Marc Evans Marc at SoftwareHackery.Com
Tue Jan 3 09:07:26 PST 2006

Hello -

I am running FreeBSD 6.0-STABLE as of Dec-15-2005 on a P4 system. I have a CDRW 
drive attached, which identifies as follows:

 	acd0: CDRW <CD-RW 52X24/K.NC> at ata1-slave UDMA33

I wish to use this device to produce CDRW backup disks periodically. I use the 
following commands to produce the backup:

 	burncd erase
 	sleep 2		# needed to avoid READY error
 	tar czf - ... | burncd data - fixate

This appears to work fine, from the perspective of the output of the commands, 
e.g. I see output like:

blanking CD - 100 % done
next writeable LBA 0
writing from stdin
written this track 633420 KB total 633420 KB
fixating CD, please wait..

My problem is that attempts to read the data back, always fail:

# tar tzf /dev/acd0
tar: Error opening archive: Error reading '/dev/acd0': Input/output error
# ls -l /dev/*cd*
crw-r-----  1 root  operator    0,  93 Jan  3 10:33 /dev/acd0
crw-r-----  1 root  operator    0, 127 Dec 30 14:26 /dev/acd0t01

No errors are shown in /var/log/messages.

I have also tried writing an ISO9660 image and mounting it, with similar 
problems at mount time.

The above said, I am able to create CD-R data disks and mount them or otherwise 
use them. I have tried several different CD-RW media, and played with -s (the 
media is rated as 12x), but have observed no changes.

Can anyone suggest solutions?

Thanks in advance - Marc

More information about the freebsd-questions mailing list