Problems reading CDRW after writing

Fabian Keil freebsd-listen at
Tue Jan 3 10:39:51 PST 2006

Marc Evans <Marc at SoftwareHackery.Com> wrote:
> I am running FreeBSD 6.0-STABLE as of Dec-15-2005 on a P4 system. I
> have a CDRW drive attached, which identifies as follows:
>  	acd0: CDRW <CD-RW 52X24/K.NC> at ata1-slave UDMA33
> I wish to use this device to produce CDRW backup disks periodically.
> I use the following commands to produce the backup:
>  	burncd erase
>  	sleep 2		# needed to avoid READY error
>  	tar czf - ... | burncd data - fixate
> This appears to work fine, from the perspective of the output of the
> commands, e.g. I see output like:
> blanking CD - 100 % done
> next writeable LBA 0
> writing from stdin
> written this track 633420 KB total 633420 KB
> fixating CD, please wait..

> I have also tried writing an ISO9660 image and mounting it, with
> similar problems at mount time.
> The above said, I am able to create CD-R data disks and mount them or
> otherwise use them. I have tried several different CD-RW media, and
> played with -s (the media is rated as 12x), but have observed no
> changes.

You could use readcd's c2scan option to check if your CD-RWs are OK.
readcd is part of (/usr/ports/sysutils/cdrtools/) if you don't have
atapicam in your kernel you have to kldload it.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list