boot problems with FreeBSD, WindowsXP (and Linux)

B _ boxxla at
Tue Feb 14 08:01:17 PST 2006

I've been having some problems with my computer arising out of an install of 
FreeBSD 5.4 which I can't seem to solve.

First of all, I started with an 80 GB HD partitioned as such:
c: 20 GB NTFS
d: 20 GB NTFS
e: 40 GB FAT

I first installed a copy of Ubuntu Linux 4.1 onto the Windows "d:". This 
worked fine, but it was only to get a look at it before putting FreeBSD onto 
the same partition. My 5.4 installation works fine and I can mount both 
/dev/ad0s1 and /dev/ad0s3 (NTFS and MSDOS respectively).

The problem is that Windows XP not fails to boot. It appears to start but 
then flashes blue and restarts the computer. Repairing with the Windows disk 
also causes a reboot and a reinstall would mean overwriting both FreeBSD 
(which I could reinstall) but more importantly the 40 GB FAT partition which 
I'd rather not loose. I don't need Windows in fact but my FreeBSD is a work 
in progress so I'd like to have a copy of Linux to tide me over until 
everything is up and working. The problem is that all of the Linux distros 
that I've tried (Fedora 4, SUSE, Mandirva, Ubuntu) have complained about the 
current partitioning scheme and want to use the entire disk.

FreeBSD's fdisk gives the following:
Disk name:      ad0
FDISK Partition Editor
DISK Geometry:  9729 cyls/255 heads/63 sectors = 156296385 sectors

Offset        Size(ST)      End           Name  PType   Desc                 
Subtype Flags
0               63             62             -         12       unused      
63             40965687   40965749  ad0s1  4         NTFS/HPFS/QNX   7
40965750   39230730  80196479   ad0s4  8         freebsd               165
80196480   1               80196480  -          12      unused               
80196481   1735019    81931499   ad0s2  4         extended DOS     5
81931500   74364885  156296384  ad0s3  4         extended DOS     5
56296385   5103         156301487  -         12       unused               0

Fdisk also complains about incorrect geometry but uses what it considers 
probably correct. And it says that ad0s2 does not begin on a track boundary. 
I cannot mount ad0s2 and I feel that it is somehow the problem.

What can I do to either correct Windows or install Linux without destroying 
my 40GB FAT partition (ad0s3)?

MSN Hotmail : créez votre adresse e-mail gratuite & à vie !

More information about the freebsd-questions mailing list