Micah micahjon at ywave.com
Wed Aug 2 03:23:50 UTC 2006

Chad Leigh -- Shire.Net LLC wrote:
> On Aug 1, 2006, at 5:44 PM, Micah wrote:
>> I'm having problems trying to get X11 to forward from an ezjail 
>> created jail environment. Here's what happens:
>> trisha% ssh -X
>> ...
>> test% xclock
>> X11 connection rejected because of wrong authentication.
> Are you doing an su or something before you run the X program?  I have 
> not had problems launching X programs in side a jail over ssh but I did 
> get that same error when I did an su first since I was no longer my 
> username.  I copied the .Xauthority over from my user into ~root and it 
> worked.  (In case anyone asks, I was testing a system management app 
> that needs to run as root to access some stuff and I was just testing it 
> for someone. I don't normally run X things at all or as root )
> Chad
>> X connection to test:10.0 broken (explicit kill or server shutdown).
>> I added "X11UseLocalhost no" to sshd_config as suggested on the lists 
>> a while back, but it didn't change anything.
>> Host is:
>> trisha# uname -a
>> FreeBSD trisha.eidolonworld 6.1-RELEASE-p3 FreeBSD 6.1-RELEASE-p3 #1: 
>> Sat Jul 15 15:48:17 PDT 2006 
>> root at trisha.eidolonworld:/usr/obj/usr/src/sys/TRISHA  i386
>> Thanks,
>> Micah
> ---
> Chad Leigh -- Shire.Net LLC
> Your Web App and Email hosting provider
> chad at shire.net

Nope I didn't su, I just ssh'd in as a regular user and immediately 
tried xclock. I also tried ssh'ing in as root to see if it's a perms 
problem, but root gets the same error. Maybe I've got a configuration 
error somewhere? ezjail mounts much of the file system ro, maybe that's 
causing a problem?


More information about the freebsd-questions mailing list