Best way to print photos

Anish Mistry amistry at
Mon Apr 3 20:22:01 UTC 2006

On Monday 03 April 2006 15:27, M. Warner Losh wrote:
> OK.  I got bordered photo printing working.  I haven't gotten
> borderless printing working, alas.
> The key points I learned:
> (1) Install print/cups.
> (2) Install graphics/hpijs.	This filters .ps -> goo the printer
> groks (3) Install graphics/gimp.	This makes .ps files
> (4) Kill lpr/lpd before starting cups.
> (5) Make sure you configure lpr/lpd not to startup on boot
> (6) Remove lp* binaries
> (7) Setup buildworld /etc/make.conf so it doesn't build lpr with
> (8) Add printer via localhost:631 web interface.
> (8) Set printer to draft mode via cups for testing
> (9) Use firefox to generate test prints.
> (10) To print from gimp, I have to remove the '-l' from the command
>      line every time I print in the printer setup.  This causes the
>      raw .ps file to go to the printer, rather than via cups'
>      postscript filter for the printer.
> (11) To get photos, one must set photo quality via cups setup
>      interface.
> #10 is was tripped me up for a long time.  That's why printing to
> the black and white printer worked for me (it was a postscript
> printer), while it failed to the color.  I hadn't noticed before
> that it printed the raw postscript and then lots of new lines. 
> Since these newlines weren't accompanied by <CR>, all text was off
> the edge of the papper, all I got was a bunch of blank pages.
> #5 bit me on boot.  Since cups replaces the /etc/printcap
> unconditionally, when lpd started it failed to start.  I lost a
> bunch of print jobs before I worked out where they had gone and why
> things had gone south.
> I'd love to know how to print borderless prints (right now I get
> 1/4" (8mm) boarder on the prints).  I'd also love to know how to
> setup gimp correctly.  However, these are really side issues now
> that I have basic functionality working.
> Thanks to everybody who was helpful in getting me to this point. 
> It got me over the hump.  My HP DeskJet 5850 is working great as a
> color printer with CUPS and my LaserJet 2200 continues to work like
> before.
> Now, all I gotta do is to figure out my OfficeJet 4200, at least
> the scanning portion...  But that can wait until my photo printing
> backlog is cleared...
I'm working on the scanning bit.  I've got a preliminary version of 
hplip ported.
I'm working on getting some feedback from the hplip folks about why, 
GetInEP is returning a bogus endpoint in the Device::Read method.  
The side-effect of this is not being able to read from the device 
(eg. scanning, and status information).  Device::Write works, so I'm 
able to at least print to my Officejet 5510v.  The key right now for 
hplip, you have to run the printer as a ugen device not ulpt.
Currently in the port Device::Read is overly complicated because it 
needs to handle it's own buffering since ugen doesn't buffer bulk 

If you'd like to try to get it setup, you need to:
1) make sure your printer is attaching as a ugen device.
2) install the port using the linked skeleton above
3) Add the following to you rc.conf:
Note:  right now those daemons run as root, I'm going to change that 
once everything is working, but for right now that was easiest.
4) Stop cups
5) You MUST start the services in the following order
/usr/local/etc/rc.d/hpiod start && /usr/local/etc/rc.d/hpssd start 
&& /usr/local/etc/rc.d/cupsd start
5) Run hp-setup and follow the prompts.
6) You should have been able to print out the test page in step 5.  If 
not, send the relevant parts of your syslog output.

Anish Mistry
amistry at
AM Productions
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list