nforce2 vs. apic

Vulpes Velox v.velox at
Thu Sep 16 14:18:45 PDT 2004

On Thu, 16 Sep 2004 14:14:55 +0300
Andriy Gapon <avg at> wrote:

> I have nforce2-based motherboard Abit NF7 and run 5.2.1-RELEASE on
> that system. I have tried to enable APIC by compiling kernel with
> 'device apic' (both with and without SMP option, although this is a
> UP system), but system just freezes during boot with it. Everything
> works pretty well without APIC, I was just curious about getting it
> to work.
> I found this discussion:
> and I have also found numerous reports on nforce2+APIC lockup
> problem in Linux and some patches that were reported to help with
> it.
> So, I want to find out if anything changed with respect to this in
> FreeBSD, maybe some patches/workarounds, or success stories about
> FreeBSD+nforce2+APIC.
> Also some notes about my lockup. It happens at this point (exerpt
> for non-verbose non-APIC dmesg):
> psm0: <PS/2 Mouse> irq 12 on atkbdc0
> psm0: model IntelliMouse, device ID 3
> pmtimer0 on isa0
> sc0: <System console> on isa0
> sc0: VGA <16 virtual consoles, flags=0x200>
> vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on
> isa0 Timecounter "TSC" frequency 1830012912 Hz quality 800
> Timecounters tick every 10.000 msec
> ipfw2 initialized, divert disabled, rule-based forwarding enabled,
> default to accept, logging limited to 100 packets/entry by default
> <<< In APIC case system freezes here >>>
> GEOM: create disk ad0 dp=0xc6e15e60
> ad0: 76319MB <WDC WD800JB-00ETA0> [155061/16/63] at ata0-master
> UDMA100 acd0: CDRW <TEAC CD-W552E> at ata1-master UDMA33
> Also, when system freezes keyboard LEDs still work properly and
> cursor disappears when I press Scroll Lock, but arrow and
> PgUp/PgDown do not work; if I try Alt-F<N> system speacker emits
> monotonic sound that can not be turned off (except by reset, of
> course).
> I am ready to provide any additional information. Unfortunately I am
> not able to use serial console, so I can't give much info for
> APIC-enabled case.

I own a Abit NF7

Yeah... I remember this. A bit... I remember having to tweak it a bit
to get it to play nicely. IIRC 5.2.1 does not have apic in by defualt?
I may just haved removed it... I forget now, but any ways. Before
trying apic, make sure your kernel has it. If your kernel does not, go
into the setup screen and turn it off. I never had any ACPI problems
with it and that has all ways worked well, minus a warning about a odd
character or the like in it at startup.

I also ran into another problem of my board not liking two ram sticks
in dual channel mode... would cause a lock up around booting... iirc
it would nearly finish and then lock up and KB LEDs would work a bit.

So far my only complaint with it has been the onboard vr ethernet chip
appears to suck compared to the dc pci card I have been using. Not
taken the time to sort that out yet. Appears some what slow under
heavy load. Think that has to do with a problem with device polling
for that chipset.

More information about the freebsd-questions mailing list