Asus A7N8X-E w/SATA and SCSI, 4.10 sys install snafu

Gary Aitken garya at
Fri Sep 10 22:40:28 PDT 2004

Just built a new system:
   Asus A7N8X-E motherboard, Athlon XP 2600+
   2 SATA seagate drives
   Old buslogic SCSI controller with 2 drives, a cd, and a tape.
   ATI compatible radeon 9000 agp 4x video card

The scsi disks have win nt images on them, from a previous system
so I can continue running it until I get a new one with both freebsd
and nt going off the sata drives.  When booted, the nt system runs fine.

I configured the mobo to boot from cd first, popped in the freebsd
4.10 cd.  However, it boots the nt images off the scsi disks instead.

So I unplugged the power from the scsi disks.  It still wouldn't
boot off the scsi cd.  Is the mobo bios too dumb to recognize a
scsi cd?

So I popped in a 4.10 boot floppy and tried again.
Turns out the boot floppy was bad,

Boot: 0:fda(0,a)/floppy

I tried to force a boot from the cd, but I'm not sure what to use
for the bios device and the device ids.  The CD is configured as
SCSI device 6.  I tried:

Boot: 1:da(6,a)/kernel -C
Invalid label
Invalid label
No /kernel

BIOS shows the following devices:

Bus Device Function  Vendor/Device  Class  Device Class            IRQ
Num  Num     Num

  0    2       0       10DE   0067   0C03   USB 1.0/1.1 OHCI Ctlr     3
  0    2       1       10DE   0067   0C03   USB 1.0/1.1 OHCI Ctlr     5
  0    2       2       10DE   0068   0C03   USB 2.0 EHCI Ctrlr       10
  0    4       0       10DE   0066   0200   Network ctlr              5
  0    5       0       10DE   006B   0401   Multimedia Device         9
  0    6       0       10DE   006A   0401   Multimedia Device        11
  0    9       0       10DE   0065   0101   IDE controller           14
  1    4       0       11AB   4520   0200   Network controller        5
  1    6       0       104B   8130   0100   Mass Storage controller  11
  1   11       0       1095   3112   0104   RAID controller          11
  3    0       0       1002   4966   0300   Display controller        4
                                            ACPI controller           9

The device on pci1 at 6.0, irq 11 is the buslogic scsi controller.

So I made new boot floppies, which booted properly.
The boot and initial probe shows the following:

BIOS drive A: is disk0
BIOS drive C: is disk1
BIOS drive D: is disk2
BIOS drive E: is disk3
BIOS drive F: is disk4

(makes sense, given that the system has a floppy (A),
two scsi disks (C,D or E,F) and two sata disks (ditto).)

md0: Preloaded image </mfsroot>
md1: Malloc disk
Using $PIR table, 12 entries at 0xc00fdea0
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Host to PCI bridge> on motherboard
pci0: <PCI bus> on pcib0
pci0: <unknown card> vendor=0x10de, dev=0x01eb at 0.1
pci0: <unknown card> vendor=0x10de, dev=0x01ee at 0.2
pci0: <unknown card> vendor=0x10de, dev=0x01ed at 0.3
pci0: <unknown card> vendor=0x10de, dev=0x01ec at 0.4
pci0: <unknown card> vendor=0x10de, dev=0x01ef at 0.5
isab0: <PCI to ISA bridge vendor=0x10de device=0060 at device 1.0 on pci 0
isa0: <ISA bus> on isab0
pci0: <unknown card> (vendor=10de, dev=0x0064) at 1.1 irq 4
ohci0: <OHCI (generic) USB controller> mem=0xe1085000-0xe1085fff irq 3 at device 2.0 on pci0
usb0: OHCI version 1.0, legacy support
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: (0x10de) OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
ohci1: <OHCI (generic) USB controller> mem=0xe1082000-0xe1082fff irq 5  at device 2.1 on pci0
usb1: OHCI version 1.0, legacy support
usb1: <OHCI (generic) USB controller> on ohci0
usb1: USB revision 1.0
uhub1: (0x10de) OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 3 ports with 3 removable, self powered
pci0: <USB controller> at 2.2 irq 10
pci0: <unknown card> (vendor=0x10de, dev=0x0066) at 4.0 irq 5
pci0: <unknown card> (vendor=0x10de, dev=0x006b) at 5.0 irq 9
pci0: <unknown card> (vendor=0x10de, dev=0x006a) at 6.0 irq 11
pcib1: <PCI to PCI bridge (vendor=0x10de, dev=0x006c)> at 8.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <unknown card> (vendor=0x11ab, dev=0x4320) at 4.0 irq 5
pci1: <unknown card> (vendor=0x104b, dev=0x8130) at 6.0 irq 11
pci1: <unknown card> (vendor=0x1095, dev=0x3112) at 11.0 irq 11
atapci0: <nVIDIA nForce2 ATA 133 controller> port 0xf000-0xf00f at device 9.0 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
pcib2: <PCI to PCI bridge (vendor=1-de device=01e8)> at device 30.0 on pci0
pci3: <ATI model 4966 graphics accelerator> at 0.0 irq 4
pci3: <ATI model 496e graphics accelerator> at 0.1
orm0: <Option ROMs> at iomem 0xc00000-0xcafff, 0xcc000-0xcd7ff, 0xce000-0xcdfff, 0xcf000-0xd1fff, 0xd2000-0xd67ff on isa0
pmtimer0 on isa0
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5, 0x3f7 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440KB 3.5" drive> on fdc0 drive 0
atkbdc0: <Keyboard controller(18042)> at port 0x60, 0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse Explorer, device ID 4
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <system console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300)
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 8250
sio1 configured irq 3 not in bitmap of probed irqs 0
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/16 bytes threshold
plip0: <PLIP network interface> on ppbus0
Mounting root from ufs:/dev/md0c
/stand/sysinstall running as init on vty0

Freebsd isn't recognizing
   the buslogic controller (bt0) device (pci1, device 6.0),
   the sata device (pci1 device 11.0),
   or either of the network devices (pci0 device 4.0, pci1 device 4.0).
Any ideas why not?

I went ahead and started the installation process, figuring I could at
least configure the SATA drives, but when I went to do the fdisk I was
informed there weren't any disks on the system.

I tried pulling the scsi adapter to see if the irq conflict was the
problem, but it made no difference.  The boot showed three disks
instead of five, but the install still failed to get off the ground
because it said there weren't any disks.

Does anyone have experience with this motherboard, in particular using
sata drives?  Any ideas what's going on, and how to proceed?
I was hoping this was going to be relatively painless :-(

Assuming the bt0 device is recognized, what is the right thing to
feed boot to boot from the CD (scsi device 6)?

One other question.  The 5 pci slots have shared irqs, and the mobo
docs say if the drivers for the devices installed in the pci slots
don't support shared irqs, then the slots have to be allocated / left
unused so that only one device is present for each shared set.  Do
the freebsd drivers support shared irqs?

Do I need to bag 4.10 and go with 5.3 to get this to work?

Thanks for any insights.


More information about the freebsd-questions mailing list