System hangs when I go from X to console (nvidia)

Graeme Smith graeme at
Thu Feb 19 10:01:46 PST 2004

I wonder if anybody has had this problem or can tell me what to try   

I installed a Geforce 2 400 MX into my machine yesterday and actually 
succeeded in getting it to work with X after 12 hours.  All apart 
from from one annoying detail anyway.  When I leave X, either by 
ctrl+alt+bs or ctrl+alt+f[1-8] or rebooting etc. the machine becomes 
totally non responsive as soon as it tries to go into console.  I 
have to switch off and switch on (no reset button) to get it back to 
life.  I think my hard drives are going to start a petition soon to 
make me stop.

I've tried the VESA, nv and nvidia drivers for X and all seem to 
exhibit this in one form or another.  I've tried loading with and 
without the VESA driver at boot with no apparent difference. At the 
moment I'm using the nvidia drivers. 

If I had to put money on what I think is happening I would say the 
card tells the monitor "go into x by y mode at z refresh" but the 
monitor can't handle that mode.  However it doesn't tell the card it 
can't deal with it, but the card is waiting for the OK from the 
monitor before it tells the machine to carry on.  That's what it 
looks like from where I'm sitting anyway.

The machine is a Compaq Proliant 800 (with embedded video which I've 
turned off on motherboard)
The card is a Elsa Gladiac 511 PCI (with twin output + TV, I'm only 
interested in getting it to work with one output)
FreeBSD is 5.2 and all ports are up to date as of this morning.

Any pointers or suggestions welcomed.

Many thanks,


More information about the freebsd-questions mailing list