strange problem with ntop

RJ45 rj45 at
Wed Nov 5 00:07:03 PST 2003

I have a dual CPU 1GHz PIII running 5.1 release.
I Run ntop on that machine.
The strange thing is that when I run ntop it hangs after a few minutes.
it uses lots of memory but I tuned the kernel accordingly setting that a
process can use up to 1GB allocation space (DSIZ etc..)
The problems looks like thread related, some thread hangs and the web page
of ntop freezes even if the ntop proces does not die.
This problem does not occour if I continuously click on the ntop web page
links to look the traffic. if I stop going through the ntop page for a
while the ntop threads start freezing.
I did not notice this problem on Linux.
NTOP is a unstable application and it is normal that it will crash after a
short time but i nthis case it does not crash but freezes a few minutes
after ntop is started. Do I have to recompile the kernel with some special
option? anyone using NTOP on FreeBSD had this problem?
thank you


More information about the freebsd-questions mailing list